Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently purchased an ASUS K55A. Like all Windows 8 machines, it come with a UEFI feature called Secure Boot. This basically makes sure that the laptop won't load anything other than the Windows 8 OEM version that came with it.

However the Asus UEFI allows for me to disable Secure Boot, and therefore I should be able to revert to Windows 7, Linux, etc. (drivers may or may not be supported). When I insert my Linux Mint boot disc and try to boot from it, though, nothing happens. There isn't even a boot priority list in the UEFI settings (I can provide screenshots later). It just says "Windows 8 Bootloader" and also on the other tab it says "WINDOWS 8 BOOT OVERRIDE".

Has anybody purchased a Windows 8 machine and successfully installed Windows 7 or Linux on it?

share|improve this question

migrated from stackoverflow.com Dec 3 '12 at 15:51

This question came from our site for professional and enthusiast programmers.

    
This belong on Super User. –  AHungerArtist Dec 3 '12 at 15:47
1  
Please don't cross post, questions can always be migrated. @AHungerArtist If you tell someone that their question belongs somewhere else this will only encourage them to post again. Rather flag the question for migration and don't comment at all. Thanks! –  slhck Dec 3 '12 at 15:58
    
sorry about that.. I realized the error and deleted the dual post. –  ARov Dec 3 '12 at 16:02
    
did you press the escape key on boot up to get the machine to load from an ISO? ASUS support told me to try this and it didn't work –  ARov Dec 3 '12 at 16:09

5 Answers 5

I believe you can press Esc during bootup to display a boot menu. See if the Linux CD/USB shows up there. If not, try to turn off UEFI Boot and then set the boot order in the BIOS:

1

As far as Secure Boot goes, here's a Secure Boot bootloader for Linux in case you're interested, and the Linux Foundation should have a valid signed pre-bootloader available sometime soon.

share|improve this answer
    
My Boot Option List only has 'Boot Option #1: Windows Bootloader'. On the SAVE & Exit screen, there is a 'Boot OverRide' which says 'Windows Bootloader' as well. I am using Aptic Setup like the screenshot posted, and UEFI is not enabled. I am using the most current version of BIOS, version 404. –  ARov Dec 3 '12 at 16:17
    
Does your version of Linux Mint support UEFI and Secure Boot? If using Ubuntu, I believe 12.10 64-bit (32-bit won't do) is the bare minimum. See the Ubuntu UEFI help page for details. –  Karan Dec 3 '12 at 16:25
    
perhaps I need to get an updated version of Linux Mint. However, with both secure boot and UEFI disabled, I don't see how this could be an issue. My challenge here is getting the BIOS to set my CD drive as a priority, and from the default BIOS settings, this is not an option. I'll post screenshots after I get off work. –  ARov Dec 3 '12 at 16:59

I got it.

The Linux Disc was dated. But more so, none of the bootable drives (not the USB, disc, etc. Only the HDD with Windows MBR on it) will show up in this BIOS unless there is media attached. For example, I have an 8 GB USB drive with 'Yummy' which is an OS loader and Windows 7 on it. The drive would not show up on the USB 3.0 side. But once inserted, the bios did see it on the USB 2.0 side. Also the CD Drive will not be available as a boot device. Perhaps it needs a bootable image that it can recognize.

Now to be safe, I will make a backup & recovery disc of the OEM Windows 8 and then proceed to wipe the drive clean. Then disable Secure Boot and Fast Boot. However, UEFI is in fact the BIOS Replacement and I was under the impression that a UEFI is typically a GUI.

Keep in mind that it may void a warranty and ASUS has said that they will not support a machine with any OS other than Windows 8 (or any future release?). So if it needs to go to RMA (Return merchandise authorization), make sure to load the OEM Windows 8 on it.

share|improve this answer
1  
You should mark your answer as accepted. –  nixda Feb 3 '13 at 22:42

I had to enable "BIOS Legacy mode" in the bios itself to even install anything pre-windows 8 on MY windows 8 HP laptop... it allowed the bios to operate "legacy" style as well as uefi.

A quote "UEFI, or Unified Extensible Firmware Interface, is a complete re-imagining of a computer boot environment, and as such it has almost no similarities to the PC BIOS that it replaces. While BIOS is fundamentally a solid piece of firmware, UEFI is a programmable software interface that sits on top a computer’s hardware and firmware (and indeed UEFI can and does sit on top of BIOS). Rather than all of the boot code being stored in the motherboard’s BIOS, UEFI sits in the/EFI/ directory in some non-volatile memory; either in NAND on the motherboard, on your hard drive, or on a network share (more on that later)."

That being said, I eventually put a triple-boot environment on that laptop - Windows XP, Windows 7 and Debian Linux. Which was kind of a PAIN to figure out, but I had to first install Windows XP, then Windows 7 whose bootloader is EFI but will also see the windows XP install and allow you to select between the two. Then I had to make a debian image that was an EFI, but also installed greb, replacing the windows 7 efi bootloader. So now on boot the laptop uefi bios loades the greb bootloader and I can choose between Windows 7 or Debian. If I pick Windows 7, I then get the choice of whether I want to boot 7 or XP. Hope that helps.

share|improve this answer

I had the same problem. In the controllpanel (of win) there is a software-setting that you can click off the secure boot in win8. That done, I finally got access to the normal boot and could access the Function-keys for choosing bootorder, bios etc. Hope this helps:)

share|improve this answer

I would try to alter the priroty of things through msconfig

so if you get to "Run" by holding down thw window key and R and then type msconfig and then try the boot screen, im pretty sure you have option on there that would help or at least slow down the process so you could see all the options.

Sorry cant be much more help.

share|improve this answer
    
Thanks, but this process is probably done before windows loads at all. Furthermore I think this question will be more relevant as more people buy new machines and discover that Windows 8 isn't what they want. –  ARov Dec 3 '12 at 15:53
    
Wrong. msconfig hsa nothing to do with secure boot. –  SLaks Dec 3 '12 at 16:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.