Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently installed Service Pack 2 on my Windows Server 2008 machine (which I use actively for development, and i'm always logged on to).

Now, after this installation, when I don't use the machine for some time (let's say, 10 minutes), it locks itself so I have to press Ctrl+Alt+Del and log back in.

I have already checked the Screen Saver settings, and it's "None", as it always has been. I also looked into power settings and everything looks right (20 mins to turn off monitor, and i haven't found any settings regarding locking me in there).

Do you have any idea what I can do so that it won't lock me out after not using the machine for a while?

Thanks!
Daniel

share|improve this question
    
You might have better luck with this at serverfault. – Joel Coehoorn Oct 5 '09 at 23:09
    
Thank you. Is there a way for me to move it (like you guys can if you close it?) – Daniel Magliola Oct 5 '09 at 23:09
2  
i'd leave it open here, some powerusers may run into a similar issue using Server2k8-as-Workstation – quack quixote Oct 5 '09 at 23:52
up vote 7 down vote accepted

Check the group policy for your account.

  • type gpedit.msc into the start search box and hit enter
  • navigate to User configuration -> Administrative templates -> control panel -> display
  • Change screen saver to disabled, and screen saver timeout to a high value just in case.
share|improve this answer
    
Thank you! ____________ – Daniel Magliola Oct 6 '09 at 2:10

What worked for me, was similar to the above...

In gpedit, navigate to Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> Security Options -> Microsoft network server: Amount of idle time required before suspending a session

then reset the timeout to the desired value in minutes.

share|improve this answer
    
Any idea how [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System] "DisableLockWorkstation"=dword:00000001 is connected to this ? – binithb Dec 2 '15 at 11:20
    
And "Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> Security Options -> Microsoft network server:Disconnect clients when logon hours expire" also sounds related. Is it related ? – binithb Dec 2 '15 at 11:23
    
The solution worked. For those who reach here for "lock" related issues after overcoming screen saver issues this is the one answer that helped. Thankyou * 1000 – binithb Dec 4 '15 at 9:02
    
"Microsoft network server: Amount of idle time required before suspending a session" - For this policy setting, a value of 0 means to disconnect an idle session as quickly as is reasonably possible. The maximum value is 99999, which is 208 days; in effect, this value disables the policy – binithb Dec 4 '15 at 9:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.