Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a way of not deactivating the mark of a region after copying it to the clipboard? (I'm using Emacs 24.2.90 and Cua-mode.)

share|improve this question

migrated from stackoverflow.com Dec 4 '12 at 8:05

This question came from our site for professional and enthusiast programmers.

add comment

2 Answers

up vote 4 down vote accepted

Add the following in your initialization:

(setq cua-keep-region-after-copy t)
share|improve this answer
    
Wow! That's perfect. Thanks! –  NVaughan Dec 4 '12 at 20:12
add comment

You can get it back using C-x C-x

C-x C-x is bound to cua-exchange-point-and-mark. It will work only if the variable cua-enable-cua-keys is set to nil.

share|improve this answer
    
You should provide the additional config which makes that work for you, because it's certainly not default cua-mode behaviour. –  phils Dec 4 '12 at 9:59
    
Thanks phils. I added some info to my answer –  Oleg Pavliv Dec 4 '12 at 10:16
    
Thanks, but I want to keep cua-mode. –  NVaughan Dec 4 '12 at 15:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.