Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a port number that I want to connect to it via net-cat. previously I was working with windows and it was working perfect; but now in Ubuntu when I want to run the Net-Cat it's show me this error : port range not valid !!!! I'm working with Ubuntu 12.04 right now ! I write this :

nc 192.168.1.10 991177
share|improve this question
2  
...what are you trying to accomplish? The error is pretty spot on: that port is not valid. A port number is a 16-bit unsigned integer, thus ranging from 1 to 65535 (port number 0 is reserved and can't be used). 991177 is greater than 65535, therefore it is an invalid port, therefore it should never have worked. –  Bob Dec 4 '12 at 11:17
    
Thnx Boby, but why it's working with windows ?! –  Sam Dec 4 '12 at 11:20
2  
Does windows use actually port 8137 when you enter that port number? (In which case it would be wrap around - mod 65536 - aka the max value for 16 bits) –  Hennes Dec 4 '12 at 11:27
2  
Once again, what are you trying to accomplish? What is your goal? It should not have 'worked', but may give the appearance of working (or just suppressed the error message), depending on what you are trying to do. Did you use the exact same command on Windows? What do you expect the command to do? Did you use the same tool, and the same version? –  Bob Dec 4 '12 at 11:27
1  
thnx Dear Boby for your reply, I want to connect to my server in command mode, which tool is the best ?! in windows I wrote exact this : "nc 192.168.1.10 991177"; beside with your solution I could connect to server via this port 65500 thnx alot –  Sam Dec 4 '12 at 11:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.