Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was previously paying for a VPS but have decided to setup a home server instead to save money.

I have a static ip address 12.34.56.78 and have registered a domain name mydomain.com.

I am running CentOS and have BIND running (I setup a Virtual Host for mydomain.com using VirtualMin, which also setup all the BIND nameserver entries for me).

The bit I am confused about is how to point my domain to my home server. In my domain management section I can change the nameservers but don't seem to have access to any DNS configuration such as A records. What do I put into the nameserver entry?

When I was using the VPS they gave me the ns1 and ns2 entries, now I am running my own server I am a little confused.

share|improve this question
    
Have you tried putting your static IP? –  terdon Dec 4 '12 at 11:50
    
I thought about that but read somewhere that it has to be a name not an IP. I will try it anyway. –  jax Dec 4 '12 at 11:53
    
I just tried it, the web interface told me that an error has occurred and would not let me change it to an IP address. –  jax Dec 4 '12 at 11:54
add comment

1 Answer

up vote 3 down vote accepted

Your domain name provider should also have nameservers available for you to use.

The details will vary with provider, but essentially are:

  1. Change the NameServers to "use our nameservers"
  2. Wait (typically this step takes between 1 - 24 hours
  3. Select "Change DNS settings" (or equivalent)

You should now have the ability to set your A and CNAME records, and will be able to add your static IP address.

Unfortunately, without knowing your specific provider, I can't provide more specific steps.

share|improve this answer
    
I am using iPage –  jax Dec 4 '12 at 11:56
    
According to ipage.com/knowledgebase/beta/article.bml?ArticleID=1776 I can change the DNS records. Unfortunately, I don't have the DNS option when I login...Maybe that is because I am currently pointing to my VPS nameservers –  jax Dec 4 '12 at 11:58
    
I updated to use their nameservers, there is still no DNS option. Maybe it will take 24 hours before it will display. Does that make any sense? –  jax Dec 4 '12 at 12:00
    
PJC, if I am using their DNS Server, is there any reason for me to have BIND running on my home server? I plan on hosting more than one domain which will point to different virtual hosts. –  jax Dec 4 '12 at 12:07
    
@jax If for all your domains you may use registrar servers, you don't need bind of your own. –  Alex Dec 4 '12 at 13:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.