Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When the user launches Excel 2010, it will open five or six windows of excel macros. I know that this is typically removed by accessing View > Macros > Remove the macro but due to the fact that Office 2010 was installed in an Enterprise environment, the ability to modify macro security settings (greyed out in File > Options > Trust Center > Trust Center Settings > Macro Settings), so the ability to click the remove button is also greyed out as a result.

Troubleshooting steps that I have tried already to resolve this issue:

  • Repairing Office 2010 in hopes of reverting to default behavior
  • Re-installing Office 2010 (and patches. UGH!)
  • Run gpedit.msc as admin and try to navigate to: User Configuration\Admin Template\Microsoft Excel\Excel Options\Security\Trust Center\VBA Macro Warning Settings (It didn't list anything related past Admin Template)
  • Disable/enable DDE
  • Perform a windows search and delete the referenced macro files after saving them to an external. Still won't die
  • Launch excel as admin (It just created a new profile for the admin instead)
  • Give user temporary elevated permissions

Basically, because the way the setting in Trust Center is greyed out (Disable all macros except digitally signed macros) the user has the ability to turn these macros on, but never turn them off.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Macros are stored to the users roaming profile. Access the roaming profile and remove the macros that you don't want to launch on startup of Excel.

Note: To be able to navigate to this folder, you will need to be able to view protected OS files for Windows 7. (Tools > Folder options > View > Unhide protected OS files)

  1. Navigate to: C:\Users\USERNAME\AppData\Roaming\Microsoft\Excel
  2. Delete the macros in question
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.