Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am the only administrator on my Window's 7 Asus x53E series laptop. Why is a standard user able to access my files by just searching my name in the start menu? If I log into guest account and search my name it shows an error that i don't have permission. When i log into my roommate's standard account and go to the start menu I put my name in search and everything I have done or searched is open to them . How can i make my administrator account private

share|improve this question
    
This has been a standard problem with Windows. There probably is a solution, but by default, Windows allows all your files to be public. Quite annoying actually. –  Josiah Dec 4 '12 at 15:45
    
This account the built-in administrator or a local account placed into the administrator user group? There is a huge difference. –  Ramhound Dec 4 '12 at 15:55
2  
What edition of Windows 7 do you have? A normal user should not be able to search or access other user's files. Double check that you roommate's account is not an administrator. Do you store you files under C:\users\yourname? –  Peter Hahndorf Dec 4 '12 at 16:02
add comment

1 Answer

By default, Windows 7 grants full control of the user folder and subfolders to the SYSTEM account, Administrators and the effective owner. Other, non-administrative users do not get any access rights to the user space. These NTFS permissions are not necessarily enforced and may be circumvented, but should prevent the straightforward accessing of files you have described.

Check whether your personal files are stored in the designated userspace %userprofile%, for instance C:\Users\Connie. Saving your documents elsewhere means you have to manage permissions manually.

Next, make sure the other user is not a member of the group Administrators. You can lock administrators out of your personal files, but bypassing this is trivial.

Finally, you could take a closer look at the permissions of the user folder (and subfolders) through the security tab in the folder's properties and untick access rights that are out of place.

Although this will keep most nosey users at bay, if you are really worried about the security of your personal files, the NTFS permissions will not suffice; use encryption instead.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.