Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a debian box running Wheezy and booting into KDE4. The computer doesn't have any monitor attached but is set to start a vnc server for remote connection when main user auto-logins on startup. The problem is that when i connect to the vnc server the resolution is messed up (something like 480x320). How can i set the desktop resolution?

share|improve this question
    
What VNC server? AFAIK there are at least 3 different VNC servers in the repository. –  Zoredache Dec 4 '12 at 19:03
    
x11vnc. The problem is not with setting the vnc server 'geometry' parameter. The problem is that the desktop screen is too small. –  Alex Linte Dec 4 '12 at 19:08

1 Answer 1

up vote 0 down vote accepted

Found the solution. I had to modify my video card's modprobe file to: options radeon modeset=0 and then add my own xorg conf file to specify the monitor details. I created the custom conf file in /usr/share/X11/xorg.conf.d/ and added only monitor parameters like:

Section "Device"
Identifier "VNC Device"
Driver "vesa"
EndSection

Section "Screen"
Identifier "VNC Screen"
Device "VNC Device"
Monitor "VNC Monitor"
SubSection "Display"
Modes "1600x900"
EndSubSection
EndSection

Section "Monitor"
Identifier "VNC Monitor"
HorizSync 30-70
VertRefresh 50-75
EndSection
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.