Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When switching to a different wireless network, I get an APIPA address after connecting. I have tried ipconfig /release / ipconfig /renew without success. Only after restarting the system am I able to get an address from DHCP. After that, everything works normally, even through multiple restarts. Only when I move to another network, even one I was connected to before, the problem starts again.

I have the following barebones laptop: http://www.asipartner.com/Solutions/Mobile/BTONotebookMatrix/tabid/114/~/Solutions/Mobile/MobileCenter/ProductFullDetails/tabid/466/sku/87776/Default.aspx

The wireless card is a Qualcomm Atheros AR9285. The driver currently in use is the native Windows 8 driver 3.0.0.130. When I tried to update it with the one from the manufacturer's website, Windows said the most current driver was already in use.

The OS is Windows 8 Pro x64. Clean install. Other applications are installed which some kind of virtual network interface:

  • SonicWall Global VPN Client 4.7.3.0403
  • VirtualBox 4.2.4r81584 (No Virtual Interfaces Currently Installed)
share|improve this question

1 Answer 1

I am 99% certain that this is a driver issue. The fact that it connects once rules out any apps, which only leaves the drivers and i the OS (and it doesn't happen to me, so its not the OS), try this:

  • Download latest driver from website
  • Go to the Win + X menu and open device manager
  • Right click on the driver and choose update driver software
  • Choose to browse your PC and locate the driver

This will force it to install the new driver for the NIC.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.