Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have got ftp working for isolate users on a windows web server running iis 7.0

I am using coffecup as ftp client to connect.

when i turn off the firewall on the server the ftp works fine. I can connect to server.

As soon as i turn on firewall i get error:

There was a problem connecting to your host or proxy. Please check your server settings and try again. If you are sure you have entered the correct information, please contact your network administrator or the server administrator. [7] Additional information: couldn't connect to host.

On firewall i have port 20 and 21 open. What else am i missing? thanks

share|improve this question

migrated from stackoverflow.com Dec 5 '12 at 0:34

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 0 down vote accepted

You're missing passive mode operation of FTP. In passive mode you're connecting to servers port that is negotiated over port 21.

netsh advfirewall firewall add rule name=”FTP Service” action=allow service=ftpsvc protocol=TCP dir=in

netsh advfirewall set global StatefulFTP disable

More info here: http://technet.microsoft.com/en-us/library/dd421710%28v=ws.10%29.aspx

share|improve this answer
    
thanks u bin looking for this for days lol –  Beginner Dec 5 '12 at 8:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.