Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In the output of any command I put into the prompt, that command is repeated (sometimes partially). What extremely simple configuration for Zsh do I need to enter to remove this repeat?

Example:

user ~ ls
lsDesktop Downloads src
share|improve this question

migrated from stackoverflow.com Dec 5 '12 at 1:18

This question came from our site for professional and enthusiast programmers.

    
Do you use colors in your prompt? This SO question might be related. –  simont Dec 12 '12 at 3:15
add comment

1 Answer 1

up vote 1 down vote accepted

You probably have a hook-like function doing that, or your prompt is doing it.

I suggest reviewing your configuration files.

FWIW, If you start a new shell with zsh -f, it will skip your configuration files and won't be echo'ing the commands anymore.

share|improve this answer
    
I am using oh-my-zsh, so the default configuration files for that is being used (along with color changes). I searched through the .zshrc and associated oh-my-zsh configs but could not see any option related to a repeated input. –  user1104160 Dec 12 '12 at 17:27
    
Turns out that there was a hidden configuration in a separate oh-my-zsh folder, thanks. –  user1104160 Dec 20 '12 at 19:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.