Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to download an update for NVIDIA here. I need this update so I can run a program that needs OpenGL 3.2+. I currently have OpenGL 3.0. I tried to install it with the following:

Doing so requires disabling X and nouveau, which I did (to my knowledge, anyway):


sudo nano /etc/default/grub
rewrite line as GRUB_CMDLINE_LINUX_DEFAULT="quiet text"
sudo update-grub

( )


sudo vi /etc/modprobe.d/disable-nouveau.conf

And write in it:

blacklist nouveau
options nouveau modeset=0


Doing so will only get me so far with the downloaded .run. When it fails, it tells me that: "the distribution-provided preinstall script failed". Searching for this gave mixed answers.

I have attempted to sudo aptitude install various versions of it (which seem to downgrade me to OpenGL 1.4 for some reason).

I have tried the ppa: http*s://launchpad.n*et/~ubuntu-x-swat/+archive/x-updates

Using the commands: sudo add-apt-repository ppa:ubuntu-x-swat/x-updates sudo aptitude update

And then rebooting. This has actually made a mess of my computer, rearranging my taskbar and making my computer fail earlier to run OpenGL (there is no error message, it just quits.) ppa-purging did not fix this (I assume I need to reinstall all the things the ppa replaced.) My issue here, though, is that I cannot get an update to OpenGL without destroying my computer, or otherwise crippling it. Help with the changes the ppa made would be helpful too, though in the worst case I can just lazily reinstall Linux.

Oh, and some information about my laptop. I am using mint 13 on a 64bit computer. I may be forgetting some information I should be giving about my setup, so don't be scared to tell me that I'm an idiot and ask for it.

share|improve this question

migrated from Dec 5 '12 at 9:46

This question came from our site for professional and enthusiast programmers.

I think those questions are better asked over at superuser – datenwolf Dec 4 '12 at 8:56
Thanks Nicol Bolas for fixing up my question. I was pretty frustrated at my computer at the time that I wrote it. When I saw that the formatting was messed up and that I needed to learn how to fix it, I just stop caring and submitted it anyways. In hindsight that was stupid and a bit rude. Also, thanks to everyone trying to help. Datenwolf, I did reboot but I did not check the modules with lsmod. I will be using that in the future. I did not know that there was a difference between superuser and stackoverflow, but I will ask my question there (with better formatting on the first edit). – Craw Dec 4 '12 at 14:03
up vote 1 down vote accepted

After blacklisting nouveau, did you reboot your machine and make sure that nouveau actually wasn't loaded. Loaded modules can be listed with lsmod. The installer scripts will fail, if there's a driver module already loaded.

Also make sure you have Linux headers and the build environment of your installed kernel installed, so that the NVidia driver installer can build the kernel module matching your system.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.