Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having trouble with keyboard shortcuts, as referenced by this link:

http://www.tomnunamaker.com/mac-os-x-lion-keyboard-shortcuts/31277/

Basically I am using shortcuts in my WordPress editor, and to insert media I press alt-shift-m, but also prints this modified  in my posts, which I have to delete each time. This is very annoying, so I'd like to disable keyboard shortcuts, how can I do that?

share|improve this question
add comment

1 Answer

One option would be to create ~/Library/KeyBindings/ and save a property list like this as DefaultKeyBinding.dict:

{
    "~M" = noop:;
}

It doesn't work in some applications (like Xcode, Terminal, or Firefox) though.

You could also create a new keyboard layout with Ukelele.

  1. Choose File > New Based on Current Input Source.
  2. Remove the output of alphanumberic keys under option and option and shift. If you remove the keymaps completely, some key combinations like ⌥← and ⌥⌫ won't work.
  3. Save the keyboard layout as bundle or XML to /Library/Keyboard Layouts/. Keyboard layouts in the user library can't be selected in password dialogs or the login window. The popovers shown when holding keys only work with the bundle format.
  4. Log out and back in.
  5. Enable the input source in System Preferences.

You can disable all other input sources by editing the HIToolBox plist. To apply changes to the keylayout file, run sudo touch /Library/Keyboard\ Layouts/ and log out and back in.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.