Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed Windows Server 2012 for development purposes at our office and noticed immediately that connecting via RDP is slow. It can take 5-10 seconds to connect at times, where as connecting to any of our Win7 or Win2008R2 boxes takes at most 1-3 seconds. At first, I chalked this up to the box itself needing a driver update or something, but just yesterday, I installed Win8 on my desk PC and connecting from home to that machine produces the same result. There is a 3-4 second pause at "securing remote connection" and then again at "configuring remote session".

I don't see any warnings in the event log, and once connected, there do not appear to be any performance issues. Is there a known problem with RDP connections on Windows 8 systems? Anything I should look for?

share|improve this question
    
Which RDP client are you using? –  Ramhound Dec 5 '12 at 16:04
    
The built in Windows 7 RDP client. –  Chris Dec 5 '12 at 16:15
    
Except on Windows 8 there is two. One that is a desktop application the other is a Windows Store Application ( Modern UI ) so which one are you using. So how are you using the Windows 7 one if your using Windows 8/Windows Server 2012? –  Ramhound Dec 5 '12 at 16:17
    
I'm connecting from Windows 7 using the desktop RDP client. –  Chris Dec 5 '12 at 16:53
    
Update the question to reflect this fact. What do you get if you try connecting Windows 8 Professional to Windows Server 2012? –  Ramhound Dec 5 '12 at 17:09
add comment

4 Answers

This has happened to me before. I solved it by going into the Remote Desktop Connection -> Experience tab and ensuring I didn't have "Detect connection quality automatically" selected. I also unchecked everything under "Allow the following".

share|improve this answer
add comment

I experienced the same issue and resolved it by adding the registry setting referred to here.

  1. Open RegEdit on the Windows Server machine.
  2. Navigate to this registry key in the tree on the left:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

  3. Right-click on the right side, and add a new DWORD (32-bit) Value
  4. Set the value name to DisableTaskOffload and the value data to 1
  5. Reconnect to the Server via RDP (to a new session) and your performance should be normal.

share|improve this answer
1  
This worked perfectly. Thanks! –  Spike Apr 2 at 20:56
add comment

You can diagnose this a few different ways -

Use the NetBIOS name, then the FQDN, then the IP Address when using the RDP application. usually this is a name resolution delay and can be resolved by using the FQDN instead of the shorter NetBIOS name. Normally, after the first connect, subsequent connections should resolve faster as the name will be cached on the local machine.

If this is a machine you will be connecting to regularly AND that machine has a static IP address, you could add it to the local HOSTS file which should result in the faster negotiation that you are accustomed to.

share|improve this answer
add comment

The problem that lead me to this page was concerning a remote desktop connection problem. I did a brand new installation of Server 2012 in VM ESXi 5.5 All the server was configured fine, DC and DHCP roles on, nothing else.

The console of ESXi was acting life a charm. Rebooting and connecting immediatly. But when it came the time to connect from remote desktop, the connection was taking several minutes before opening up. I didn't understand why because on the 2008 box besides it was fine!

Well all this time, the problem was related to Remote Registry service being Stopped. I wasn't able to start it because it was saying something about the connection user not the same than another related service.

Resolution: manually change the Connection settings in the Remote Registry setting for NT Authority\LocalService and no password required. Now the RDP connection goes well and it connects right after I enter my domain admin password.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.