Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Previously, on Vista and Windows 7, changing the Default Playback device would occur instantly.

For example, audio is coming out of my speakers, I right click the Volume Control, click Playback Devices then I select another device and click Set Default. Audio would be transferred immediately.

Unfortunately, now, with Windows 8, I need to kill whatever process that's outputting sound and restart it for the change to take effect.

Is there something that can be done about it so that changes are taken into account immediately?

share|improve this question
What exactly are you switching between? Headphones will automatically switch as Buster said, so unless you are doing something different you won't require the manual switch over. – Sam Jan 5 '13 at 10:29
I'm switching between two "Speakers" devices (ASTRO Gaming USB MixAmp and standard speakers), so it's not headsets that I plug in when I want to use them, both are plugged at all times – emartel Jan 5 '13 at 19:57
up vote 4 down vote accepted

I just figured this out myself. If you don't want to restart the program, simply "configure" and "test" the playback device. That is, after setting the default device, click "Configure" toward the bottom left. Click "Test" in the "Speaker Setup" window that appears. Then simply click "Next" twice and "Finish" and you're done. Whatever you're trying to do will now play audio on the desired device.

share|improve this answer

I don't know, but you may not need to do that to get back the behaviour of Vista and Windows 7. Try the drivers from RealTek, which don't seem to provide two Playback Devices - there is just "Speakers" - but the sound switches correctly when you plug and unplug headphones.

share|improve this answer

I had made scripts using NirCmd, and assigned them to buttons in Total Commander, based on this tutorial. It is written for Windows 7, but works great for Windows 8.1, too.

Switch playback device using Logitech G key

share|improve this answer
- Right click volume icon
- Playback devices
- Right click device you want to set default
- Set default on popup
share|improve this answer
This is not an answer to the original question. The OP tried this and said it doesn't work in his question. – DavidPostill Oct 3 '14 at 7:08
I dont know why it doesnot work with him. I was try and the sound was change to device i choose. My Os is window 8.1 – Grey Wolf Oct 4 '14 at 15:13
@GreyWolf could be a fix in Win 8.1? The question is about Windows 8 though and your solution didn't work on that platform. I don't run Windows 8.1 so I cannot validate if your solution works, but all in all, it still wouldn't answer the initial question. – emartel Apr 28 '15 at 20:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .