Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

this is my first post on superuser though I hang out on Stackoverflow a fair amount.

Disclaimer, I'm an OSX noob. Anyway, this one has me stumped. When I go to the Apple Store and attempt to install Xcode version 4.5.2, I see this error:

Xcode can't be installed on MacOSX because Mac OS X version 10.7.4 or later is required.

However, when I open a shell and do a uname -a I see:

Darwin xxxx 10.8.0 Darwin Kernel Version 10.8.0: Tue Jun 7 16:33:36 PDT 2011; root:xnu-1504.15.3~1/RELEASE_I386 i386

Looks to me like that says I'm running 10.8.0. Just in case, I did manual check for software updates, there were a couple. I installed them, rebooted, still seeing the same thing.

EDIT - Forgot to mention, I also tried downloading Xcode and installing from the .dmg, but saw the exact same error.

What am I missing?

Thanks

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Mystery solved. uname reports the kernel version. When selecting "About This Mac" under the Apple menu it reports that I'm actually running OSX version 10.6.8. Sigh.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.