Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So my Windows 7 had a BSOD from an Ati driver file then restarting only gives me some wierd coloured lines at the top of the screen. Starting in safe mode causes the boot up to freeze at AtiPcie.sys and overlays the same coloured lines on the safe mode start up display.

It seems to be a problem with the display driver but I can't get into the OS at all to uninstall it. Luckily I have an old install of Windows 7 from when I moved to a SSD still on my HDD and that runs just fine so I'm pretty sure its a software problem (Maybe the SSD corrupted a driver file or something).

So does anyone know how I can uninstall the driver files from another Windows 7 install on the same PC?

EDIT: What I mean is, I'm running on the broken PC right now but using a different HDD's windows install. I have full access to the not booting up OS drive with the Windows so I can delete any files/load the registry etc...

share|improve this question
    
do you have a system restore point you could revert to? –  JackeJR Dec 6 '12 at 9:43
add comment

1 Answer

Probably your last chance is to run Startup Repair and hope that it can disable the offending driver. This may get you far enough that you can boot into Safe Mode and completely uninstall it.

While you're in Startup Repair you can try removing the offending driver files in \windows\system32\drivers: atikmdag.sys and atipcie.sys. This also might let you get back into the computer in Safe Mode.

But based on your description, it sounds more likely that the problem is with your actual hardware; you may have overclocked your CPU too far, undervolted your RAM, and/or burned out your video card.

share|improve this answer
    
The thing is, I'm running another Windows install on the same PC right now. It is working fine right now so it can't be any kind of hardware failure alone. –  nar Dec 6 '12 at 3:59
    
In that case, it's definitely a driver issue, and please read the rest of the answer. :) –  Michael Hampton Dec 6 '12 at 4:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.