Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't get it to work. Here's exactly what I did:

  1. Create a new Azure VM, Windows Server 2012.
  2. RDP to the new VM
  3. Download & Extract Squid for Windows (2.7.STABLE8)
  4. Rename the conf files (squid, mime & cachemgr)
  5. Add the following lines on the end of squid.conf

auth_param basic program c:/squid/libexec/ncsa_auth.exe c:/squid/etc/passwd.txt
auth_param basic children 5
auth_param basic realm Welcome to http://abcde.fg Squid Proxy!
auth_param basic credentialsttl 12 hours
auth_param basic casesensitive off
acl ncsa_users proxy_auth REQUIRED
http_access allow ncsa_users

  1. Use http://www.htaccesstools.com/htpasswd-generator-windows/ to create passwd.txt
  2. Test passwd.txt via c:/squid/libexec/ncsa_auth.exe c:/squid/etc/passwd.txt (success)
  3. squid -z
  4. squid -i
  5. net start squid (No errors so far).
  6. go to https://manage.windowsazure.com, Virtual Machines -> myVM -> Endpoints
  7. Add Endpoint:

Name: Squid
Protocol: TCP
Public Port: 80
Private Port: 3128

That's it. Unfortunately, it doesn't work. I think I screwed something up at the endpoint? I'm not sure.. help?

EDIT: I'm testing it via Firefox -> Options -> Advanced -> Network, and the exact error is "The Proxy Server is refusing connections." I'm using my DNS as the Proxy server "abcdef.cloudapp.net" and port 80 (since that's my public endpoint).

share|improve this question
add comment

1 Answer

Is port 80 open in the Windows Firewall?

For example, from an elevated command prompt you could run the following to enable port 80 inbound:

netsh advfirewall firewall add rule name=HTTP dir=in action=allow protocol=TCP localport=80

To test if a port is listening is with PsPing:

http://technet.microsoft.com/en-us/sysinternals/jj729731.aspx

psping abcdef.cloudapp.net:80
share|improve this answer
    
I already configured the firewall to allow port 80. I tried psping, and the Azure VM still refuses the network connection :( –  LantisGaius Dec 8 '12 at 5:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.