Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The official documentation of NTFS-3G states that you need to create a mapping for drive-spanning NTFS symlinks because it obviously can't map Windows drives to Linux mount points:

Another option is to let the user define what a drive letter should be mapped to in Linux. Such definitions should be located in the .NTFS-3G directory of the current file system, as symbolic links to the matching moint point. C:\Users will be converted to ./.NTFS-3G/C:/Users with C: being defined as a symbolic link to some mount point.

This is the case, as this ls -lisah shows:

224031    0 lrwxrwxrwx 2 root root   40 Aug  5  2010 creations -> /media/Daten/.NTFS-3G/W:/

So basically I need to create a symlink named "W:" in /media/Daten/.NTFS-3G that enables file lookups to the correct mount point. But the problem is... how am I supposed to create a colon in a filename on a NTFS partition?

It simply does not work:

strayer@layer:/media/Daten/.NTFS-3G$ ls -lisah
insgesamt 13K
105347   0 drwxrwxrwx 1 root root   0 Dez  5 21:38 .
     5 12K drwxrwxrwx 1 root root 12K Dez  6 09:47 ..
105348 512 lrwxrwxrwx 1 root root  42 Dez  5 21:38 W -> /media/truecrypt1
strayer@layer:/media/Daten/.NTFS-3G$ LANG="" sudo ln -s /media/truecrypt1/ "./W:"
ln: failed to create symbolic link `./W:': Invalid argument

Not surprising, since a colon is forbidden in NTFS file names... how am I supposed to make this work?

My first hope was that NTFS-3G would ignore the colon in the filename and just use the already existing "W" symlink, but it does not.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

As explained by the NTFS-3G lead developer in their support forums:

Actually NTFS allows colons in name, only Windows does not. Your symlink creation is probably rejected because you mounted the partition with option windows_names. If so, you can probably temporarily mount without the option while creating the symlink, and set the option back afterwards. The special characters are only checked when creating a file (whether regular or special).

After mounting the volume without windows_names I was able to create the symlink with a colon in its name.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.