Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a MS Word 2010 document with many small tables. I would like to prevent those tables from breaking up over pages. I know it is possible to prevent a single row to break up. But I would like the following:

  1. How can I prevent a table from breaking up over several pages?
  2. How can I do this for one or several tables at the time, instead of setting it per row?
share|improve this question
Seems to have been asked before and answered here. – pnuts Dec 6 '12 at 11:13

5 Answers 5

up vote 9 down vote accepted

Yes you can. Highlight the entire table by clicking the icon with the arrows at the top left of the table. Then click Paragraph Properties from the toolbar and tick Keep with Next.

share|improve this answer

I don't think there is a setting to allow the entire table to stay on the same page, simply because your table may be too long to contain within a single page.

You can get the table on its own page by inserting a page break before and after the table. From the Insert menu choose Break > Page Break to insert a manual page break.

You can also adjust properties for multiple rows os a table by selecting the whole table before setting row properties. Hover on the top left corner of the table to get the table selection icon which looks like a + with arrows on its ends.

share|improve this answer

In my situation, I was inserting a table from Excel into Word. Since the table was too long to stay on one page I copied as much of the table that fit, pasted it in Word, then pasted the rest of the table right next to it.

So basically you can just create the table in parts so it fits on one page.

share|improve this answer

Select the space just above the table down to the end of the table. Right-click and the paragraph properties option will be available, select the 'Keep with next' option. No need for additional page/section breaks.

share|improve this answer

The problem with setting the entire table to "keep with next" is that this forces the paragraph after the table to stay with it. If this is a problem you need to select only as far as the penultimate row before setting the paragraph properties, not the end of the table, which gets a bit messy when you subsequently add rows to the end of the table as you have to remember to keep adjusting the paragraph settings.

I seem to remember that it was possible to prevent a table splitting across pages in earlier versions of Word using a table property, which seems much more logical, but alas that seems to have gone...

share|improve this answer
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – Ramhound Sep 29 at 12:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.