Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I mount NFSv4 export via /etc/fstab and mount and use the shared folder in nautilus.

There are two issues:

  • When I copy a large file (around 4 GB) to the NFS server, the progress bar rapidly goes to 2 GB and then basically stops moving. But the copy s still in progress - it is just not displayed well
  • When I disconnect from the network without unmounting the nfs share, nautilus freezes.

How can I work around that?

/etc/export on the server

/export/share   192.168.0.0/24(rw,sync,insecure,no_subtree_check,anonuid=1000,anongid=1000)

/etc/fstab on the client:

server:/share   /mnt    nfs4    soft,tcp
share|improve this question

1 Answer 1

I would use automount. It mounts/unmounts the share automatically when it is accessed/not accessed. I don't think it will affect the progress bar problem but it should fix the freezes.

Have a look at my answer here (specifically, steps 5-7) for more information on how to set it up.


UPDATE

I found that the file manager will hang if the shared volumes are linked to (or directly mounted) in my home directory. By placing links to my mountpoints in a sub directory of $HOME I had no more freezes.

The problem is that autofs will mount the share each time it is accessed, that includes ls. So, every time you open nautilus and you have the mount linked to or mounted in your $HOME, it tries to mount it and hangs.

So, my current (hang-free) settings are:

  1. NFS share mounted at /mnt/shared/movies
  2. It is linked to in a sub directory of my $HOME:

    $ ls $HOME | grep shared
    shared
    $ ls -l $HOME/shared
    lrwxrwxrwx 1 terdon terdon 20 Feb 15  2012 movies -> /mnt/shared/movies
    

This way, the volume will only be mounted if I do an ls $HOME/shared and not a simple ls $HOME.

Finally, make sure you are using the -soft option.

share|improve this answer
    
Nope, not working here. I managed to configure autofs and it automatically mounted the share, but if I disconnect the network. Nothing is unmounted and if I click on a file in the share, nautilus freezes. –  Alex Dec 7 '12 at 15:55
    
@Alex, see updated answer. –  terdon Dec 7 '12 at 16:12
    
I am having the soft option in the /etc/auto.server file and my share is not mounted to $HOME - it is mounted in /mnt. Still, when I have the share open and disconnect, everything hangs. –  Alex Dec 7 '12 at 17:27
    
@Alex and it is not linked to anywhere else? –  terdon Dec 7 '12 at 17:40
    
No it is not - mount shows only this one connection managed by autofs –  Alex Dec 7 '12 at 18:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.