Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For no apparent or obvious reason, the files of my usb-flashdisk (32gb) are not visible/gone.

The drive is located, I get an 'autoplay' dialogue and all the folders are visible, but all the files (photo's, documents, .rar's, everything) is not visible (or gone...) The folders show no contents, and the properties also show 0 bytes. The drive itself, on the other hand, shows that roughly half of the space is used.

I tried several usb ports and different pc's, but there is no difference.

What is the next step?

share|improve this question
  • try a data recovery tool/file system scanning to see whether the file system is just corrupted
  • open up the drive itself (most drives are snap lock designs. Easy to pry open using a sharp knife). Look for physical damage. In this case, my guess is that it's possible that the first chunk of the flash memory is unaffected but the chunk which actually holds the data is in trouble. Look for a gap between parts that should be in contact. It may only take a bit of bending to get back access to your files (had this problem before. Used a soldering iron to weld back relevant points)
  • I've seen something like this with my one of my optical drives. Basically, anything it wrote would show up as zero sized files after written. It was only when I updated the firmware would things act normally. Try on a newer machine
  • power problem. There is a malfunction electronically somewhere (on the drive itself or on your system). Power issues can result in a ll sorts of strange anomalies including possibly this
  • use a different Operating System (Knoppix, a Live Linux Distribution is probably best suited to this) to see whether it is specific to it. Had something similar before where a NTFS filesystem would show up normally under Linux but corrupt under Windows
share|improve this answer
  1. click start>>run>>type in "cmd"
  2. type the location of your flash drive.. e.g. "d:", "e:", "f:", etc..
  3. type "dir /ah" *you will now see the files/folders with hidden attributes
  4. type "attrib [name of file/folder] -r -a -s -h" *if you're going to unhide files, you should type the whole name plus the extension (format).. example "attrib party.jpg -r -a -s -h" **if you have folders with 6 characters and above, type the first 6 characters then "~1".. example for folder named "birthday" "attrib birthd~1 -r -a -s -h"
  5. you should repeatedly type dir /ah after unhiding some files/folders so you'll know if they're now working or not..
  6. now check you flash drive.. it should be there..

heres another possible fix

  • On the view tab CHECK "show hidden files and folders".
  • UNCHECK "Hide protected operating system files".

You will see your missing folders/files which were hidden by the virus. navigate through your these folders and just copy the files in them to a new location.

If neither of those work try this data recovery tool

share|improve this answer
I get a "file not found". Also when I'm in command prompt navigated to a specific folder. – Joris Dec 6 '12 at 14:27
nope, the procedure after your edit (which I already tried) is also no solution... I hope this does not mean I have lost all content... – Joris Dec 6 '12 at 14:30
If you cant find your data in either of those ways its very possible the flashdrive corrupted. I will edit with a link for a data recovery tool – MalwareManiac Dec 6 '12 at 14:35
the tool looks good, and I'm sure it has done his job well, but it dit not return any files. at this point I'm sure the files are gone somehow. thanks for the tips though – Joris Dec 13 '12 at 15:05

Run a CHKDSK command (Check disk) from a Admin level DOS prompt, or from the Disk properties (Right click drive in my computer : Properties : Tools tab : "Check now" button in windows 7). This will check the directory structure, which sounds like the problem here. I am old school so I usually type this into a command prompt and if the drive was F: then it would be --


I like to do this without the /F flag to start with, so that it is "read only" and you can see what issues are likely to be fixed if you run it in fix mode. What you are hoping for, most of the time, is "No problems found". For a USB this should run at any time assuming files are not already open, on the C drive you have to schedule it for a reboot.

Sometimes a drive will not appear at all because the drive letter it is assigned is in conflict. That doesn't sound like the problem here, but a look into DISKMGMT.MSC might be a good thing too (type this into Start : Run). This will tell you how the drive if formatted and the partitions, and its "Status" (Healthy?).

Your USB might have gotten into this state by being pulled out at just the wrong time, and not dismounted gracefully.

share|improve this answer
Bad advice. You run a lower level recovery program first, before attempting CHKDSK. I have explained this in my answer here – Jan Doggen Feb 16 at 11:27

You must log in to answer this question.

protected by Community May 29 '14 at 13:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .