Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

An external IDE harddrive that I have has recently stopped working quite suddenly, when tried in other computers it is not even recognised by the BIOS or by a Linux recovery disk. I assumed that the fault must be with the PCB, but there is no visible damage to the board.

In my research, the problem seems to be often caused by a fried chip on the PCB but the board looks fine to me. The drive may have made some unusual noises briefly before it died but honestly I can not be sure. One day I turned it on and it just did not spin up and was not recognised.

For your information it is a WD Caviar, model number WD2500BB-22GUCO with board number 2060-701266-001 REV A.

What could cause a drive to no longer recognised by the bios, and what are some fixes I can try? Is it possible that the PCB is still the culprit despite me not being able to see any visibly damaged components?

Many thanks, Ben

share|improve this question
1  
It is unlikely that you would be able to see any fault with the naked eye, beyond a blown capacitor. A chip that has been fried by a static charge is not going to look any different than a functional one. –  Don Simon Dec 6 '12 at 15:26
    
Register the drive with WD and replace it under warrenty if its eligible. You might even be able to purchase recovery insurance for a very good price ( WD offers reasonable price recovery services ) and get a replacement and your data back. –  Ramhound Dec 6 '12 at 16:40
    
@Ramhound thanks for your help. Unfortunately it is well out of warranty, which hints towards it being a problem with the hard disk itself. But thanks for the info on WD insurance, I did not know that. –  Ben Jackson Dec 6 '12 at 16:54
    
@DonSimon Well that is good news, perhaps a PCB replacement could still be fruitful. Can I just confirm, a static charge could happen all by itself before I touched it, right? The only static charge problems I am familiar with is when someone has been working on the drive, but this happened well before I removed it. –  Ben Jackson Dec 6 '12 at 16:56
    
@BenJackson - If you had dust it might be possible but ESD requires a non-grounded transfer point which is unlikely unless its being touched. I should point out WD has specific eligability terms on their recovery services. –  Ramhound Dec 6 '12 at 17:27

1 Answer 1

Actually I would say the problem is with the hard drive itself especially since you say it made a funny noise. In my experience with this issue 95% of the time the hard drive ended up being replaced.

Some things you can try to verify this:

  • Hook up the drive to a working computer and run chkdsk on it.
  • If you have a know good drive you can try to boot up your machine with that.
  • Try to boot up your pc with a linux boot disk

If the computer boots with a boot disk then the hard drive is almost definitly the problem

Also if you have to replace the drive and recover data this tool works excellent!

share|improve this answer
    
Thanks for your help, but as I mentioned, the drive is not recognised by the bios in any PC, so I am unable to run chkdsk. Booting was not mentioned as a problem, instead the problem is that the drive is not recognised by the bios even if I attach it as a slave to another PC which does boot. –  Ben Jackson Dec 6 '12 at 17:00
    
ok ya i missed that you had tried it in other computers but i think that further proves the drive is bad. Are you saying that drive will boot fine? –  MalwareManiac Dec 6 '12 at 18:01
    
The drive was never a boot drive (it doesn't contain an operating system). But no the drive does not spin up. What solutions could I personally pursue if the problem is with the drive itself? –  Ben Jackson Dec 6 '12 at 18:38
    
If the drive doesnt spin up that is a huge problem cause that also rules out data recovery unless you wanna pay the couple hundred bucks to send it somewhere... i would just buy a new one and start fresh –  MalwareManiac Dec 6 '12 at 18:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.