Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have some files which have Russian characters in the file names. How can I get Windows to display those characters (see screenshot)?

I do seem to have what is needed to display Russian. These files contain some Russian text and, when I open these files, I can see the Russian characters.

share|improve this question
    
See superuser.com/a/503165/52492 (I've no idea if it helps but it may be worth trying) –  RedGrittyBrick Dec 6 '12 at 17:43
    
There is a convmv package in cygwin. It converts between file name encodings. Would you care to try it and report back? –  Ярослав Рахматуллин Dec 6 '12 at 18:13
add comment

2 Answers

up vote 1 down vote accepted

The problem isn't Windows Explorer, file names were corrupted somehow in the filesystem. Filesystem in Windows supports U+04xx cyrillic character range, but file names in your case have U+008x..U+00Fx characters instead.

How did you get these ones? If they were extracted from archive, then delete them, set Windows-1251 as code page for non-Unicode programs in Control Panel, and expand that archive again. If they were written under Linux via ntfs-3g/vfat driver, then reboot into linux, mount Windows partition correctly and copy these files again. So, you got the idea: it's filesystem who needs to be fixed, not the Explorer.

share|improve this answer
    
Yes, I did get it from an archive. How do I set the code page setting? –  sax Dec 6 '12 at 17:57
    
In your original post, someone wrote a comment. Click the link and see 2 first pictures –  Kitet Dec 6 '12 at 18:11
add comment

Question is where you got them, right? I'm getting this with Japanese files, when sent to me in ZIPped form, that's why i decided to answer. If you were send them like i say, ask sender to resend packed with RAR, it will encode names in unicode. Alternate way is to alter your system locale to the same one your sender has, like RedGrittyBrick said, and look if you see tchem properly. Then rename them one by one, and Windows will also encode them with unicode, so you could revert to your original locale and see the names properly (this is a longshot, i admit).

share|improve this answer
    
I got them as a zip file. Too many files to rename. –  sax Dec 6 '12 at 17:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.