Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a flash drive that I'd like to format for use in Windows. I would like support for symbolic links, so I can't use FAT/FAT32/exFAT.

I would prefer to use the ext4 filesystem and disable journaling, with the Ext2Fsd filesystem driver, but have (so far) found that I can't make soft links across filesystems that Windows will read, Ext2Fsd has an annoying bug about always mounting partitions as read-only and has problems resuming from sleep, and some programs have problems writing to the partition even after manually configuring Ext2Fsd to allow writes.

So, I would like to use NTFS for the flash drive, but disable the journaling feature (causes extra writes), if possible. How can I do this?

share|improve this question
Could you make a normal NTFS filesystem, but disable journaling on the host machine? like – sep332 Dec 6 '12 at 18:33
Downvote: Anyone care to explain why? – palswim Dec 6 '12 at 19:08
@sep332: Nice find. You should put that in an answer! – palswim Dec 6 '12 at 19:33
up vote 1 down vote accepted

I don't know of any tools to create an NTFS filesystem without a journal, but you can delete the journal after you make the filesystem. On Windows, open an administrator command prompt and type:

fsutil usn deletejournal /d c:

Where c: is the drive you want to remove the journal from.

As you might expect, there are some dangers involved with this:

share|improve this answer
This answer is incorrect. That command deletes the USN journal ($Extend\$UsnJrnl), not the NTFS journal ($LogFile). – benrg Jul 8 at 9:09

You cannot. Neither Ntfs.sys on Windows nor NTFS-3g on Linux allow disabling specific filesystem features.

On the other hand, I've been using NTFS on my flash pendrive for over 4 years and it's still working perfectly – journalling has even saved my data a few times.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .