Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Gow and am using plink to SSH into remote servers. The problem is, when I attempt to edit a file remotely with Vim, it doesn't utilize the entire screen's space. I changed the original command prompt's size via View > Console Window but that changed nothing.

Also, the escape key isn't sent to the remote server. So it's nearly impossible to edit files (I've had to use the old Ctrl+[ trick in Vim to get out of editing mode).

Another oddity is that if I am on the last line in the window, and attempt to go down one line in the buffer, it only updates the last line. The above text doesn't get updated.

When I attempt to use PuTTY (on its own), that is included with Gow, it works fine. When I attempt to use Vim locally it also works fine. Maybe there's some command that I need to send to plink? OR maybe there is something I would set in the .vimrc file? I was able to force the window size of Vim (on the remote server) by setting 'set lines=50' and 'set columns=180' but this is not ideal. And the single line scrolling issue is also still there.

share|improve this question
Which terminal emulator are you using? Does Gow include xterm, urxvt, or MinTTY? Or does Console2 itself support terminal emulation nowadays? – grawity Dec 6 '12 at 23:50
I've experienced that problem with plink and console2 as well, and I'm afraid I don't have an answer. I tried running it through ansicon to console2 as well, which solved the screen space issue, but introduced even worse problems. Eventually I had better luck using this Windows port of OpenSSH through console2. – Fopedush Dec 6 '12 at 23:56
up vote 0 down vote accepted

PuTTY works, because it includes a full terminal emulator along with a SSH client. However, plink is designed for raw data transfer, not interactive use, and does not send the tty dimensions to the server (nor does it interpret the ANSI escape sequences).

share|improve this answer
This make sense. What I ended up doing to fix it is call: putty -load ENV -l user -new_console. The -new_console being the important flag. Now it attaches a PuTTY terminal session as a tab which is awesome. This solves all of my remaining problems with the editor. – echamber Dec 7 '12 at 6:55
-new_console in ConEmu's feature ) – Maximus Dec 8 '12 at 12:58

This is the problem of Gow's ssh client. ConEmu's user had similar problem which was fixed after switching to "proper" ssh client (Git ssh AFAIK).

And try ConEmu as alternative console? (I'm the author)

share|improve this answer
"Git ssh" is a Cygwin port of OpenSSH. Cygwin has a terminal emulation layer that transparently converts between ANSI sequences and Windows console API. – grawity Dec 7 '12 at 19:06
@grawity ConEmu is terminal that supports ANSI sequences internally and much more (tabs, splits, quake-style, macros, default terminal and more and more) – Maximus Dec 8 '12 at 12:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .