Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to just enter a number for the amount of inventory we have. I do not want decimal places and I want to type in the number without it rounding.

For example when I type in 6, it reads as 0.06 and rounds to 0. I just want to see 6 in the cell and I want it to be a number.

share|improve this question
    
Please try @barry houdini's answer and mark it as answer if it works for you. I just tried what he proposed and it solved the weird behavior. – Marcus Mangelsdorf May 6 at 9:30

The cell you're typing in is probably formatted as a percentage, with one decimal place. Right-click the cell, click "Format Cells", and open the Number tab. Select the "General" number type.

Note that if the number is solely for human reading, and you won't ever need to do calculations on it, the "Text" format is better, as it will accept the input exactly as written.

share|improve this answer
    
It is formatted as number with no decimal place. I can't use text as the cell will be part of a formula – Jeanne Hesselberg Dec 7 '12 at 14:25
2  
That's fine then. The "General" type should be sufficient for your needs. – Jonathan Garber Dec 7 '12 at 14:32
    
but when I type in 6, It registers 0.06 and rounds to 0 – Jeanne Hesselberg Dec 7 '12 at 15:11
    
Thanks for the edit Jonathan, you obviously had the right Excel version at hand ;-) – Jan Doggen Dec 8 '12 at 18:41

If you enter 6 and it appears as 0.06 you have Excel set up to automatically add decimal places.

Change that like this depending on your Excel version:

Excel 2010

  • Click on File Menu at top left - select Excel Options then go to Advanced and under Editing Options uncheck the automatically insert a decimal point option.

Excel 2007

  • Click on Office button at top left - select Excel Options then go to Advanced and under Editing Options uncheck the automatically insert a decimal point option.

Excel 2003

  • In Excel 2003 and earlier versions you can access this option through Tools > Options > Edit > uncheck Fixed decimal Places.

Once you have done that make sure your cells are formatted to General or Number (zero decimal places) and when you enter 6 you will see just 6.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .