Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Win 7 Pro x64 machine on a company domain network does not have the ability to add a USB printer for some reason. All other computers do.

In the Add Local Printer section, there's no USB001 (Virtual Printer Port for USB) option.

I tried doing several Google searches, found a few tricks, but nothing seems to work. I created a local port, labeled it USB001 and installed the driver, but the printer does not print anything.

Any ideas?

share|improve this question
1  
So, what happens when you plug in the printer - does the OS detect it? –  Dave Dec 7 '12 at 14:30
    
The HP built-in Utility asks me to install it. However, it fails during the install. –  Markaway Dec 7 '12 at 14:34
    
Any error message or details as to why? What does event viewer suggest (if anything)? –  Dave Dec 7 '12 at 14:55
    
No error message. Just says to unplug printer, shut off, turn on, then plug back in and try again –  Markaway Dec 7 '12 at 18:15
    
Event log doesn't show anything. –  Markaway Dec 7 '12 at 18:22

1 Answer 1

That port is only created when you install a USB printer. It's not there by default. Follow the manufacturers instructions for your printer installation.

share|improve this answer
    
I tried installing the driver from HP's web site, from the CD it came with, and from when you plug in the printer, it has that built-in driver install feature. None of those options work. At some point during the install, it fails. –  Markaway Dec 7 '12 at 14:34
    
Go to device manager and see if there are any warning on printer or usb devices. Point that device to your printer driver. –  BroScience Dec 7 '12 at 14:36
    
Nothing appears in DM related to the printer –  Markaway Dec 7 '12 at 14:47
    
Ok, then unplug all of your USB devices from the machine. Uninstall all USB devices from device manager, reboot, after your system devices reinstall plug the printer back in. –  BroScience Dec 7 '12 at 14:52
    
Tried that and still won't install. Even did a system restore going back 2 days ago. Same problem. –  Markaway Dec 7 '12 at 18:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.