Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use cmd console very frequently as Administrator to run our build scripts. But it is not possible to change the compatibility settings of the cmd.exe in windows menu. The whole Compatibility tab is greyed out as you can see in the picture attached below. This machine is a company machine, but I'm able to set up lot of things on it and, on the other hand, I'm able to change these settings, I mean the Compatibility tab, in case of other software, e.g. Visual Studio, Total Commander, etc.

Is there any way to change it and does anybody know why the whole tab is greyed out?

Thanks in advance!

The Compatibility mode is greyed out.

share|improve this question

migrated from Dec 7 '12 at 19:20

This question came from our site for professional and enthusiast programmers.

I note that the only setting you could apply to a terminal on this list is "Run this program as an Administrator". i just checked, mine is the same as yours. I use a shortcut to cmd pinned to my task bar, and I have the shortcut set to run as administrator (shortcut properties -> advanced -> Run Program as administrator) and that works well for me. – Frank Thomas Dec 7 '12 at 19:34
up vote 6 down vote accepted

does anybody know why the whole tab is greyed out?

It gives the answer to that right in your screenshot enter image description here

cmd.exe is a component of windows and can not have compatibility settings set.

Even though you can not set compatibility on the exe itself if you create a shortcut to the exe you can set it to always be administrator from the shortcut's Advanced... menu.

enter image description here

This should give you what you want.

share|improve this answer

That's exactly how it's supposed to be. This is normal behavior.....

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .