Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two users in Ubuntu. My first was me and I am the owner of the folder in question. The second is my wife. Netatalk is running and we can both see the folder on the network. I can access it but she cannot. She gets an error in OS X:

… you don't have permission to see its contents

I have use chmod 777 on the folder but it made no difference. Any ideas?


The directory in question is a mounted harddrive at /media/ourPhotos

ls -lh /media/

I am trying to share "Mir Yannick", shared group is "shapiras"

total 112K
drwx------ 1 isaac isaac     24K Dec  1 10:52 Belboz the Magnificent
lrwxrwxrwx 1 root  shapiras    7 Aug 18 16:17 floppy -> floppy0
drwxrwxr-x 3 root  shapiras 4.0K Dec 16 03:28 floppy0
drwx------ 1 isaac isaac     48K Dec  1 10:51 Frobozz Magic Memory Device
drwx------ 1 isaac isaac     28K Aug 20 16:23 Mir Yannick
drwxrwxr-x 3 root  shapiras 4.0K Aug 20 09:01 Network Trash Folder
drwxrwxr-x 3 root  shapiras 4.0K Aug 20 09:01 Temporary Items

AppleVolumes.default

/davidtennant Tardis allow:isaac cnidscheme:dbd options:usedots,upriv,tm
/media cnidscheme:dbd allow:isaac,jessica options:usedots,upriv
/media/Mir\ Yannick allow:jessica options:usedots,upriv

df -T

Filesystem     Type      1K-blocks       Used Available Use% Mounted on
/dev/sdh1      ext4     1939812036 1193632920 649089428  65% /
udev           devtmpfs    3047700         12   3047688   1% /dev
tmpfs          tmpfs       1222604        900   1221704   1% /run
none           tmpfs          5120          0      5120   0% /run/lock
none           tmpfs       3056500        740   3055760   1% /run/shm
/dev/sdb1      fuseblk  1953512444 1504702472 448809972  78% /media/Mir Yannick
/dev/sdg1      fuseblk   976759804  873042100 103717704  90% /media/Belboz the Magnificent
/dev/sda1      fuseblk   976759804  703015860 273743944  72% /media/Frobozz Magic Memory Device
share|improve this question

2 Answers 2

up vote 1 down vote accepted
+100

netatalk by default share out home directory, which I guess that is what you are using.

For your wife to connect to your ubuntu home directory on OS X

  1. Open Finder
  2. Click Go on top menu bar
  3. Click connect to Server...*
  4. Type in afp://ubuntu-server-ip, click Connect
  5. A box should pop up ask for Name and Password, type in your username and password

To share common folder between different users:

  1. On Ubuntu create a new group with

    addgroup sharefolder
    
  2. Add all users to that group

    adduser username1 sharefolder
    adduser username2 sharefolder
    
  3. Umount the ntfs external drive, then remount it.

    At this point, it is very dependent on how package mount.ntfs or ntfs-3g is built. It may automatically pick up the new sharefolder group assigned to user and set it in acl list. Which is not obvious in ls -l < mount point >. If that is the case, restarting netatalk will fix the issue.

    If the above do not apply, then it can be fixed by mount option describe below

    1. Find out GID of group sharefolder

      id -g sharefolder
      
    2. Set GID when mounting (assume sharefolder gid=1004)

      mount -f ntfs /dev/sdb1 <mount point> -o gid=1004
      
  4. Restart netatalk

    service netatalk restart
    
share|improve this answer
    
Its not the home directory, its a mounted hard drive. I didn't realize that was significant. My apologies, I have edited my answer. –  Fresheyeball Dec 16 '12 at 8:44
    
But can your wife access that share with my method? –  John Siu Dec 16 '12 at 8:45
    
Well she can access her home folder fine, thats the method we where using actually. And she can see the folder in question too, but it got a red circle on it in osx and says she does not have permission to access content. –  Fresheyeball Dec 16 '12 at 8:50
    
She has to "umount" her home folder, then "mount" your folder with your login. You can only use one credential with a server at a time. You cannot connect as A to Folder-A and as B to Folder-B at the same time to a single server. –  John Siu Dec 16 '12 at 8:53
    
Are you telling me that netatalk is not capable of sharing the same folder to two different accounts? –  Fresheyeball Dec 16 '12 at 9:05

It seems that your directory permissions are incorrect. Netatalk cannot override system permissions, that is, the directory must be accessible to the user as if they were on the computer. In this case, you own the drive "isaac", the group is also "isaac", and have the perm 0700. You need to change the group of the folder to one that "jessica" is in, and change the permissions to 0770. This will allow anybody in the group rwx. If you have files on the drive that only you want access to, change the perm to 0700, so the group has no access.

I could be wrong, but I believe netatalk needs x permission on a folder to show the contents.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.