Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a remote desktop connection (from my home) to the company's server. On this I opened a Remote Desktop Connection Manager and inside this connect to a specific server.

I was busy copying a file but this task never ends. So I kill the process and now I have a blue screen and no more taskbar. Very frustrating. When I try CTRL+ALT+END (=CTRL+ALT+DEL) this is executed on the main server and not the server which gives me the blue screen. I don't know if I'm clear.

I know I should have keep Task Manager open and type Run... explorer.exe but I closed it.

Any help is really appreciated!

share|improve this question

migrated from stackoverflow.com Dec 8 '12 at 9:42

This question came from our site for professional and enthusiast programmers.

1  
Is this really suited to SO? –  Arran Dec 6 '12 at 19:03
    
Sorry I will ask the question on Stack User –  Bronzato Dec 6 '12 at 19:04
    
You can try to disconnect/terminate session and connect again and log in with different user this time - this should start another explorer.exe process and give you full GUI. If this remote server has Remote Procedure Calls enabled and you have proper right you can try to use this guide: anandthearchitect.wordpress.com/2008/08/01/… and log off the session remotely. I recommend RWINSTA. If it will require from you the remote server admin rights to do so - then use command RUN AS to start RWINSTA as specific user. –  mnmnc Dec 21 '12 at 23:28

4 Answers 4

I get into this problem and I solved it this way:

  1. Close the RDC to the specific server (session keeps running).
  2. In the "proxy" server, open "Remote desktop service manager" (you can found it in Start menu, "Administrative tools", "Remote desktop services").
  3. In the management console, right click on the tree root ("Remote desktop service manager") and on the context menu click on "Connect to computer".
  4. Input the specific server name or address and connect.
  5. When connected, you can see your session in the main panel of the console. Select it and choose "Close session" from right panel.

Now you can connect to the specific server using RDC and a new session will open and you will have the task bar.

share|improve this answer

This is expected behavior, as your home's Remote Desktop Connection will only inject the Ctrl + Alt + Del keystrokes in the machine it is directly connected to. This won't end up in the nested session.

Your best bet would be to keep Explorer running at all time. I'm assuming you were copying a file using the clipboard redirection. In this case, simply disconnecting and reconnecting should be enough to abort the operation and get you back on your way.

share|improve this answer

Your access rights on the server might prevent this from working, but you can try create a second connection as yourself on the server by running this from your command prompt:

MSTSC /admin 

(MSTSC.exe is Remote Desktop)

then connect & login as usual.

Once logged in, go in task manager, in the user tab you should see your new session as well as your previous self showing "disconnected". Right-click and do Log Off on it to end that session.

By the way, /admin is also useful in that you can create a 3rd connection when the maximum of 2 users is reached.

share|improve this answer
up vote 0 down vote accepted

I solved my problem with + + then I can access my Task Manager.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.