Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a serious problem which drives me crazy because I tried everything I could think of.

First of all, I made a video: but please read the following text for more information, not only view the video!

When using a USB-to-Serial interface everything works as long as I don't go beyond 57600 Baud. At higher rates I only get giberish like this:


What makes the problem so strange is, I exchanged every component and the problem still presists. I tried differtent OSes (Ubuntu, WinXP, Win7, OSX 10.7) with 32 and 64 Bit. I tried USB-to-Serial interface from FTDI and Prolific. I tried reading the output from my Raspberry PI and from an Asterisk Appliance. I changed the cables and the wiring. Nothing helped.

In the video I made a example with a old Notebook with native COM and put the USB-to-Serial to the same connection as "sniffer" (only Rx and GND connected) to make sure the output and everything is ok as one can see on the native port. The voltage is ok. Settings for both are 115200 Baud, 8 Bit with 1 Stop and no flow control. Native is ok. USB is messed up.

I used the newest drivers and double checked all connections. I have no idea what is wrong here. As I couldn't find anyone describing problems like this I question my long experiance in computer science and think I'm doing some completly wrong... Please help :-/

share|improve this question
I've used (as probably others have) USB-serial adapters at 115200 baud. One of the cheaper adapters does have a signal ground issue. The GND on the RS-232 side is not connected to the USB GND; some connections (depending on chassis ground connections) produce garbage data. Are you reporting that all setups over 57600 baud have problems? Is there any common piece of equipment involved? What is that breadboard in the video? Is that a homemade level-shifter? – sawdust Dec 8 '12 at 20:18
I did not try higher values than 115200, so I can not surely say they make problems aswell. The breadboard is used to split the signal so I can use it on the native port and the USB-to-Serial one. No electrical parts there except some wires. My USB-to-Serial device has an open (wire) end and I applied a RJ45 jack to it, so I can definitly say the GND is connected correct. Without connecting it I get no output. So I think this should be OK. The fact that many others use this adapters without any problems is exactly the part of the problem that drives me crazy... – Mose Dec 8 '12 at 20:26
Splitting the signal could be problematic. If there are just wires, then does that mean that there is no line termination to cancel reflections (which can get worse as frequency goes higher)? – sawdust Dec 8 '12 at 20:41
Yes it could be a problem, but not in this case. I just wired this up to demonstrate the problem better. The problem was experienced without any of this "sniffing" stuff. I just wanted to show that the device is spitting out it's data right by showing it simultaniously. – Mose Dec 8 '12 at 20:53
9600 seems perfectly fine, 115200 produces garbage data at the front. – linsongyang Feb 9 '15 at 10:30
up vote 4 down vote accepted

After thinking it through and finding a single post which was a little bit in the right direction I figured out it is the only remaining possibility to invert the signal and give it a try. Fortunately FT232RL has option flags in it's EEPROM (programmable with "MProg" by FTDI) to set this:


After this, everything worked on every Baud rate. Don't ask me why, I have no technical explanation for it. I'm looking forward to get an oscilloscope for further investigation. Never saw such a strange problem before.

I tested my USB-to-Serial with a Cisco Switch too and it didn't work without this inversion.

share|improve this answer
Any update on this issue? – Isaac Sep 10 '14 at 21:06
Worked for me too - the tool is called FT_Prog now - available here: – MrMajestyk Jun 24 '15 at 9:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .