Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Linux Mint on an SSD. I've read how one optimization is to disable journaling. However, when I run the command:

sudo mke2fs -t ext4 -O ^has_journal /dev/sda1

I get an error saying that the drive is busy. Well, of course it's busy, that's where the whole OS is.
How can I disable this?

share|improve this question
    
As in all *nix systems, you have to go into single maintenance user mode, unmount the volume and then do your changes from there. Otherwise the other option is to carry the drive over to another system, install it as a secondary drive, leave it umounted and carry on the operation from there. –  Fiasco Labs Dec 8 '12 at 22:30
    
Well, I'm pretty much an idiot, so not sure how to enter single maintenance user mode. It looks like I can do that through the grub boot menu, but I don't know how to get that menu to show up. –  Andi Jay Dec 9 '12 at 0:02
add comment

1 Answer

As written in the manpages mke2fs is used for creating new filesystems, not changing existing ones.

I think the tool you are looking for is tune2fs, it can use the same parameter:

tune2fs -O ^has_journal /dev/sdXY

Whatever you do, make a backup before you play with filesystems.

You might have to use the -f (force) parameter.
Check the manpages with man tune2fs before using the tool (and make a backup, seriously).

share|improve this answer
    
I will look into that. Thanks. –  Andi Jay Dec 9 '12 at 0:03
    
@AndiJay, using the command you attempted (mke2fs) would have caused you to loose all your data since a new filesystem would have been created, overwriting your existing one. It is the equivalent of the windows "format" command. –  terdon Dec 9 '12 at 0:22
    
I don't mind if I wipe everything by mistake. There's nothing important in the machine. –  Andi Jay Dec 9 '12 at 0:28
    
ok, I made a bootable USB key off the mint .iso. I booted into recovery mode, adn I was able to run the tune2fs command. My question is, how can I confirm that journalling was actually shut off? –  Andi Jay Dec 9 '12 at 0:51
1  
+1, Worked for my pen-drive on Arch without forcing. But I think you mean tune2fs -O ^has_journal /dev/sdXY (forgot the 2); that may cause confusion for future readers. –  JMCF125 Jan 24 at 20:58
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.