Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 PC that is using a Wireless network connection that I want to share on the PI. I have a working CAT 5 cable that I am using to connect the Win 7 PC to the PI. I have configured the Windows 7 PC to share the network, Windows states: Unidentified network shared.

However on the PI I get nothing, I've tried several IP based commands and I can't seem to identify anything.

I had it working from a direct cable before, but now I'm using the cable from the PC I cant seem to get it to work.

I have followed the commands on the R.Pi site, but anything I try doesn't seem to work.

I'm using Raspbian “Wheezy”.

share|improve this question
    
Apparently the NIC on the R-Pi is auto-sensing. So plain/cross cables should not be the problem here. Might want to add that to the post before you get people asking you to try it with a cross cable. Also, does the Pi detect link? Does the PC detect it? What happens if you plug either end of the cable in a switch, does the link come up (if not, faulty cable, not faulty type but broken). –  Hennes Dec 9 '12 at 0:04
    
hi ive started trying 'sudo /etc/init.d/networking stop|start and its now saying "DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 6, it tries this several times and then drops out with No DHCPOFFERS recieved. Unable to obtain a lease on first try. Exiting. Failed to bring up eth0. –  Welsh King Dec 9 '12 at 0:21
    
DHCP on Windows 7 is turned on –  Welsh King Dec 9 '12 at 0:28
    
What happens if you set up a static route (pi: ifconfig eth0 172.16.1.1 netmask 255.255.255.0, windows same with 172.16.1.2, set up routes (in case those do not get set automatically) and try to ping the other? That should allow ping. –  Hennes Dec 9 '12 at 0:36
    
ive just tried something simlar setting both to be the same. The network service starts, but nothing works, when i do a ping it just sits there. –  Welsh King Dec 9 '12 at 0:41

1 Answer 1

The simplest solution would be to just enable ICS, but that does not seem to work with Win7 Starter Edition or if the NIC of the wireless adapter does not have any "share" option (perhaps caused by the network adapter driver).
Another way is to bridge the wireless and the wired connections by selecting them both and then just selecting the appropriate option from the context menu.
Or you could use e.g. Connectify to accomplish what you want, but that requires a software installation.

share|improve this answer
    
im using ICS on Windows 7 Premium, but when i use it it says it cant find DHCP "DHCPDISCOVER on eth0 to 255.255.255.255 port 67" Cant bridge the connection as it requires 2 lan connections. –  Welsh King Dec 9 '12 at 15:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.