Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Thinkpad Edge E130, and the LCD screen's backlight has 15 hardware steps.

$ cat /sys/class/backlight/acpi_video0/max_brightness 
$ 15

I'm currently running Linux with LXDE as desktop environment, and this is the problem:

  • Before login to LXDE, the backlight works fine. With Fn+F6/Fn+F7 I can set all the hardware steps
  • After login, I can set only 8 steps. I think that both LXDE and ACPI increase one step for every Fn+F7 pressure (8*2 "=" 15).

I've tried to add the following kernel boot parameters:

  • acpi_backligh=vendor
  • acpi_backligh=vendor, acpi_osi=Linux
  • acpi_backligh=vendor, thinkpad-acpi.brightness_enable=1 (according to this wiki)

In all the case the backlight completely stops to work, so I think that acpi_backligh=vendor is not helpful in my case.

I have also tried with video.use_bios_initial_backlight=0 kernel parameter, but nothing seems to happen (always 8 steps).

Suggestions?

share|improve this question
    
I am using xfce4 on a T510 and I have 8 steps up and 5 steps down, I recognized irregularities in the pattern but didn't really care. Until now… damn you…! –  Baarn Dec 9 '12 at 11:13
    
@Informaficker Sorry! I hope that my fix can help you. –  ital Dec 9 '12 at 11:45
    
Please don't edit your solution into your question, write an answer yourself. This is totally OK here on StackExchange (actually it is the way you should do it here). You should accept your answer as soon as you are able to, too. –  Baarn Dec 9 '12 at 11:55
    
And thanks for finding the solution. –  Baarn Dec 9 '12 at 11:56
    
Thank you, answer added. –  ital Dec 9 '12 at 12:13
add comment

1 Answer

up vote 2 down vote accepted

After some searching, I find the following solution: just a simple

# echo -n 0 > /sys/module/video/parameters/brightness_switch_enabled

Of course this needs to be done at every boot (the way depends on the specific distro).

Many thanks to arch linux guys

share|improve this answer
1  
There is no need to do it at every boot, it should be enough to specify the parameter value for modprobe in a file like /etc/modprobe.d/video-local.conf with the line: options video brightness_switch_enabled=1 –  meden Feb 10 '13 at 0:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.