Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have dual booted Ubuntu Linux 12.04.1 LTS on my Samsung Series 5 ChromeBook, and am trying to run/install Oracle VirtualBox (from the generic .run file downloaded from their website). However, every time I try to run it (as root from the command line), it gives me the following error occurs:

Please install the build and header files for your current Linux kernel.
The current kernel version is 3.4.0
Problems were found which would prevent VirtualBox from installing.

I have tried the version from the Software Center, as well as the command line installation, both of which gave me errors based on my linux-headers/linux-kernel/linux-[kernel]-image.

Here's an error I keep getting (on the command line):

First Installation: checking all kernels...
It is likely that 3.4.0 belongs to a chroot's host
Building only for 3.5.0-18-generic
Building initial module for 3.5.0-18-generic
ERROR (dkms apport): kernel package linux-headers-3.5.0-18-generic is not supported
Error! Bad return status for module build on kernel: 3.5.0-18-generic (x86_64)
Consult /var/lib/dkms/virtualbox/4.1.12/build/make.log for more information.
Setting up virtualbox-qt (4.1.12-dfsg-2ubuntu0.2) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

...And one of the more cryptic errors I get when trying to start any Virtual Machine:

Result Code:      NS_ERROR_FAILURE (0x80004005)
Component:        Machine
Interface:        IMachine {5eaa9319-62fc-4b0a-843c-0cb1940f8a91}
share|improve this question

migrated from stackoverflow.com Dec 9 '12 at 11:14

This question came from our site for professional and enthusiast programmers.

    
Isn't VirtualBox in the Ubuntu repositories? –  Blender Dec 8 '12 at 23:33
    
in the cloud??? –  iphonedev7 Dec 8 '12 at 23:33
    
Yes, but I've tried that already...and it gave me an error similar to the one above. –  iphonedev7 Dec 8 '12 at 23:34
    
Try to type this before: sudo apt-get install linux-headers-$(uname -r) –  cheesemacfly Dec 9 '12 at 1:52
    
I have (and just did) try, but to no avail :( –  iphonedev7 Dec 9 '12 at 1:56
show 2 more comments

2 Answers

Do these links help you? try to start with those...

share|improve this answer
    
let me check... –  iphonedev7 Dec 9 '12 at 1:05
    
no...unfortunately they didn't because they apply to fedora, while I'm using Ubuntu 12.04 (12.04.1, technically speaking) –  iphonedev7 Dec 9 '12 at 1:19
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Oliver Salzburg Dec 9 '12 at 11:23
    
@OliverSalzburg : Yes, I agree, that would be quite helpful –  iphonedev7 Dec 10 '12 at 0:28
add comment

I found these links very helpful:

This is probably the best one (or atleast the one that has produced the most promising results so far): https://wiki.ubuntu.com/KernelTeam/GitKernelBuild

Here are two others that were somewhat helpful:
A Discussion in Google Groups:
https://groups.google.com/forum/#!msg/chromebook-central/PPQFpC7mYzk/yW2hfNd7OHUJ
and
A Blog post: http://compilethekernel.blogspot.com/2011/08/compile-linux-kernel.html

Good Luck and Happy Compiling!!!
-iphonedev7

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.