Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My work uses Microsoft Exchange. I can not receive this mail on my iPhone because my exchange account slot is being taken up by my Google Sync account. I can't seem to get IMAP or POP to work for the life of me.

I have resorted to simply forwarding my work email to a gmail work account I created. The only problem I have is when I reply to emails that come to my gmail work account the recipients see my @gmail email instead of my @work email.

Is there anyway to change this Reply To setting? I know I have done this with many blackberries. It is just an option under Blackberry Internet Service. Does iPhone have this option some where and I just do not see it?

share|improve this question

3 Answers 3

With ActiveSync (i.e. Exchange type account) Here's how to work around this problem;

  1. Go to Settings > Mail, Contacts, Calendars > [Your Google Sync Account] > Account Info and change the Address field to the email alias you normally send from (this will be use as the default when ever you want to answer emails)

  2. Create other email accounts by following these instructions with one exception. On step 7 enter the email alias instead of your GMail address for both the address field. You may want to use good description for this "bogus" account.

  3. Once you have done the final save, tap on the account you've just created and erase the Incoming Mail Server Host (imap.gmail.com). It's important to leave this field blank since it will prevent you from receiving duplicate email. It will however still allow you to send outgoing from the email account you've just created

To select the source email address when you reply simply tap on the from field and a rolodex will let you select your from address.

They are two caveats to this however

  • The iPhone mail application will not select the from address automatically. It will always default to the email address you've set at step 1 even if you are replying to an email sent to one of the aliases.

  • Since this involve creating a "bogus" account in the iPhone mail application every time you'll hit the refresh button you'll get an error message stating that the iPhone cannot retrieve email from the dummy account. The error repeats itself for every "bogus" account.

Some other people may like to know that for any IMAP account in the iPhone Mail application you can always go into Settings > Mail, Contacts, Calendars > [Your IMAP Account] and change the Address field to a comma separated list of email address that are associated with that account. Since the field will not let you put in a comma directly you'll need to use paste the list in the field. The list itself should look something like this:

myFirstAlias@company.com, mySecondAlias@company.com, myThirdAlias@anotherdomain.com
share|improve this answer
    
The suggestion to use a comma-separated list for generic IMAP accounts was exactly what I was looking for. –  David Citron May 19 '12 at 4:38

If you're using IMAP to access your Gmail account from your iPhone, your From: address can be set in Settings > Mail, Contacts, Calendars > [Name of your Gmail account] in the Name and Address fields.

If you're using ActiveSync (aka Push), Gmail will use the the name and primary e-mail address you can set here: https://www.google.com/accounts/EditUserInfo

share|improve this answer

There's no option for something like this. The built-in Mail app doesn't have a lot of customization options, unfortunately.

share|improve this answer
    
No known workarounds? –  CT. Oct 6 '09 at 17:22
    
Maybe if you'd try a different mail app (I haven't tried any others, but there might be some available). Other than that there's no way of doing it. –  alex Oct 6 '09 at 17:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.