Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some time, I've been using DD-WRT (DD-WRT v24-sp2 (06/14/11) std - build 17201) on a Netgear WNDR3700 v2 router. Yesterday, I found that the 2.4 GHz network had become open and that the Shared Key field of Physical Interface ath0 was blank. I've put the shared key back in and find that it usually disappears when I hit Apply but doesn't disappear if I click Save. I've tried rebooting the router, choosing different combinations of Security Modes and WPA Algorithms with no luck. The shared key stays with the 5 GHz radio.

Here's what the Wireless Security page looks like:

Wireless security page

The build name and version doesn't match what's on the dd-wrt site but the build date does.

Any ideas?

Thanks

Mike

share|improve this question
    
I have this exact same issue. Did you find any solution? –  Deepak Mittal Feb 24 '13 at 7:45
    
No, it got worse (e.g., started loosing internet connectivity regularly, lost dhcp/dns configuration). I replaced it with an ASUS RT-AC66R. That got us back onto the internet in about 1/2 hour leaving a few issues which have now been resolved. –  mikebk Feb 24 '13 at 16:08
    
So you mean its not dd-wrt but the hardware itself? It looked more like a dd-wrt bug. Maybe VLAN caused it (even I have two APs configured). I'll try disabling one of them and see if it fixes the issue. –  Deepak Mittal Feb 24 '13 at 19:30
    
If it helps, I've never done any vlan configuration. I could have tried to reload ww-wrt and then get samba and VPN going but I didn't. The ASUS router has a better wireless range as a bonus. –  mikebk Feb 25 '13 at 1:06
    
I fixed the issue by reflashing latest build of dd-wrt from dd-wrt.com/others/eko/BrainSlayer-V24-preSP2 –  Deepak Mittal Feb 27 '13 at 11:00

2 Answers 2

SOLUTION FOUND: I had the same problem immediately after adding additional static host entries. I tried to set the password manually using the nvram command, but the setting cleared after a reboot. Finally, I went & cleared some old static host lease entries, and moved the newer one up to fill the blank spaces. I was then able to set the WPA shared key, and it remained after a reboot. Thank Goodness! I've made so many customizations to this router that I'd hate to have to upgrade the firmware and reconfigure from scratch.

share|improve this answer

I had the same issue with a Buffalo WZR-HP-6300NH. My network suddenly went down and came back up (I hadn't touched router settings in weeks, if not months). After it came back up, it wouldn't keep the password on the wireless anymore, despite setting it, saving it and applying it. I had two SSIDs setup (both with passwords, one was for guests and isolated from my private network), the second guest SSID worked fine, but I couldn't get the first private SSID to work again.

I tried re-flashing the DD-WRT firmware on the router (without resetting to factory default), but it didn't work.

The only way I could fix this issue was by resetting to factory defaults.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.