Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows 8 + 3g Vodafone modem. I want to share internet via wifi so my friend can use it from mobile phone.

I've tried to use this instructions: http://www.techseeks.com/how-to-make-windows-8-laptop-a-wireless-access-point.html

  1. I've set "Allow other network users to connect through this computer's Internet connection". I've set "Home networking connection" to "WiFi".

  2. I've executed C:\Windows\system32>NETSH WLAN SET HOSTEDNETWORK MODE = ALLOW SSID = MYW530 KEY = pwd

The hosted network mode has been set to allow. The SSID of the hosted network has been successfully changed. The user key passphrase of the hosted network has been successfully changed.

  1. When I was tring to execute "C:\Windows\system32>NETSH WLAN START HOSTEDNETWORK" I receive such error:

The hosted network couldn't be started. A device attached to the system is not functioning.

WiFi adapter is eneabled! Why network can not be started and how to fix the problem?

share|improve this question
add comment

2 Answers

Check device manager for "Microsoft Virtual WiFi Miniport Adapter" under Network Adapters. If it is not there then step 2 didn't work. Most likely you don't have permissions on your machine to set this up.

share|improve this answer
add comment

Try these steps:

  1. Disable and then Re-enable your WiFi adapter(Device Manager > Network Adapter > Wifi Adapter).
  2. See if your Microsoft Virtual WiFi Miniport Adapter is turned on.
  3. Check weather hosted network is supported by your wireless card. Type the following in cmd with administrator privileges: netsh wlan show drivers.If you find a line which says "Hosted Network Supported: Yes" only then you'll be able to create a hotspot.
  4. Alternative to cmd you can use Virtual Router or Connectify with gives GUI to manage your wireless hotspot.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.