Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a wired connection of about 36Mb/s, but my wireless speed is max at about 18-19Mb/s. I have a WRT54G-TM (T-Mobile, 802.11G) router with DD-WRT firmware - I've upgraded it to latest build. Done some settings changes:

  • changed channel - 13
  • wireless network mode - G-only
  • ACK Timing - 0
  • Fragmentation Threshold and RTS Threshold - 2304
  • Basic Rate - All

Signal/Noise ratio: -46/-94, signal quality ~50-60%. Is this normal with G networks?

Edit: The AP is located about 2 meters from laptop, no walls or metal objects, but its next to a TV. I've done a channel scan (had problems locating it, go to "Status -> Wireless -> Site survey" - lame naming) and everybody else is on channels 1 and 6. Switched to channel 11 but it didn't help. As for trasmit power I got best results with default 71mw. The antenna might be a factor, I'm using the default 2 antennas.

[edit] Upgraded my AP to a 802.11N capable router (TP-LINK TL-WR841N) and now my speeds are always maxed. I recommend everyone this solution.

share|improve this question
1  
Based on my search 802.11g supports 6, 9, 12, 18, 24, 36, 48, 54 Mbit/secs. So if you are only getting 50% signal getting 18 Mbit/sec seems to be correct. I had to upgrade to 802.11n for exactly the reasons you have discovered. If you are in the states channels above 11 are not supported by many devices. –  Ramhound Dec 10 '12 at 13:01

3 Answers 3

Sounds unsurprising. There are lots of things that can affect the performance of the wifi AP.

Including:

  • Interference
  • Other nearby Wifi AP's & devices on the same channel (neighbours?)
  • Walls
  • Metal objects
  • Distance of device to AP
  • Antenna gain
  • Transmit power.

In DDWRT there is a menu option that allows you to "scan" for other devices. Use that to determine the presence of other Wifi routers that the AP is seeing. Choose the quietest channel and retest.

You're getting plenty of signal too so it's most likely some sort of interference.

By the way, channels above 11 are not commonly used. And I once tried channel 14 but found it was limited to something like 5 or 10MHz of bandwidth and did find documentation on this but haven't located that yet. So do try other channels.

share|improve this answer

It isn't uncommon to see that the theoretical max speed of wireless does not match the real world speed.

However there are other options that you can play with in the advanced settings in DD-WRT that might improve your speed.

Other options that might be of value include enabling Frameburst and afterburner. Make sure you test as this could potentially make the performance worse. Also read up the max values suggested for your transmit power. For my router an asus rt-n16 its different, its in dB not mW which is why it is a much lower value. This is an exception. Your router, which I've had before, is definitely in mW. Generally the default value for this is just fine.

enter image description here

You may also want to change your wireless adapter settings on your computer. This is outlined here and also here.

If you have the options there for frameburst or afterburner enable it. You'll want to test after each of those changes.

If you have a transmit power option set it to the highest or max performance rather than max power savings. There shouldn't be any negative effects from this except for battery life.


For future reference. I left this for others but I saw you did this already in your edit:

As mentioned in the other comment. Wireless channel is important because you don't want to be on a channel that interferes with a neighbors wifi network if possible. The best channels to select are 1, 6, 11. I prefer 1 and 11 as the frequency of channel 6 is close to the operating frequency of microwave ovens - 2450Hz -and I've found interference with it personally. To see what channels other wifi routers in your area my be running at go to Status then click wireless.

enter image description here

Then at the bottom click "site survey"

Site survey pop up

Here is a list of my neighboring wifi routers. The closer the noise level is to -100 the worse the signal is, meaning they're far away and likely not to cause interference should you select that channel. You can click on the titles to sort by that column value. It won't show your router.

For reference this is what mine looks like. I would say I have moderate interference.

enter image description here

share|improve this answer
1  
I've never had any luck with afterburner. I don't recommend setting it it made the link unstable and some clients had trouble connecting. –  Matt H Dec 11 '12 at 22:10
    
Yeah you do need to mess with it and it depends on the clients. –  Blisk Mar 1 '13 at 15:09
up vote 1 down vote accepted

I've googled for "maximum 802.11g speed" and found several threads, including superuser reporting that a G network will max at about 22-25Mb/s.

Also Wikipedia about 802.11g: "It operates at a maximum physical layer bit rate of 54 Mbit/s exclusive of forward error correction codes, or about 22 Mbit/s average throughput."

So it is a normal speed, I got it a bit better (max about 22,5Mb/s) by enabling afterburner and frame burst features (thanks Blisk!). Guess its time to get me a N access point.

share|improve this answer
    
I get 40 - 50 Mbit/s on mine. –  Matt H Dec 13 '12 at 21:07
    
@MattH And what is you wired max speed and how did you measure? –  Bartlomiej Skwira Dec 14 '12 at 13:52
    
Using iperf. It varies a little. I'm using tomato and wrt54gl. Although recently I upgraded to an N router and get much better performance. –  Matt H Dec 16 '12 at 20:13
    
Using Iperf I get about 12mb/s, but when I go to speedtest.net I get around 21-22mb/s. Strange. Thought I would get a better result with Iperf –  Bartlomiej Skwira Dec 29 '12 at 13:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.