Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a laptop that did have Vista on it but due to misuse it is hosed, so I am dual booting Ubuntu 9.04 and XP on it.

I ran the Ubuntu live cd, partitioned the hd into 3 partitions (one ntfs, one fat32-shared drive for both OSs to access, and ext4 for ubuntu)

I installed Ubuntu fine no problems. When I go to install XP I get the error:

alt text

I searched Google and do not really understand the problem nor a simple way to fix it. I have tried formatting the XP partition using gParted on the Ubuntu live CD but that didn't solve the issue.

Any help?

share|improve this question
    
I know this question is already solved, but was this a stock XP CD, or one with the service packs applied? Prior to XP SP1, there was an issue in XP where it didn't recognize HDDs larger than 137GB. –  Powerlord Oct 6 '09 at 14:57
    
This was an XP cd with SP2 on it I believe –  Mike Fielden Oct 6 '09 at 16:49

2 Answers 2

up vote 3 down vote accepted

It's more than likely your hdd/RAID drivers. I had the same problem with my laptop & linux. Look in the BIOS and see if there's a setting for your HDD controllers. I had to set mine from 'Enhanced SATA' to 'Compatible Mode' for everything to work correctly.

Patrick is correct though, you should install XP first, otherwise your GRUB install will be hashed when you reinstall XP and won't be able to boot your linux install.

share|improve this answer
    
That worked like a champ Thank you –  Mike Fielden Oct 6 '09 at 14:53

This isn't the only way, but it's easier to install XP first, and then install Ubuntu. Windows doesn't like to play nice with Linux, but Linux will play nice with Windows.

share|improve this answer
    
I should have mentioned that I tried that first :) but it didnt work so I thought I was being neat to install linux use gParted, partition it, install xp, then run grub but that didnt work... stupid windows :P –  Mike Fielden Oct 6 '09 at 14:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.