Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Linux Mint Nadia (Cinnamon), when I run

sudo apt-get update

I got the following set of error; note that I removed http://’s due to Super User’s spam filtering.

Fetched 173 kB in 13s (12.5 kB/s)
W: Failed to fetch archive.canonical.com/ubuntu/dists/nadia/partner/source/Sources  404  Not Found [IP: 91.189.92.150 80]

W: Failed to fetch archive.canonical.com/ubuntu/dists/nadia/partner/binary-amd64/Packages  404  Not Found [IP: 91.189.92.150 80]

W: Failed to fetch archive.canonical.com/ubuntu/dists/nadia/partner/binary-i386/Packages  404  Not Found [IP: 91.189.92.150 80]

W: Failed to fetch dl.google.com/linux/deb/dists/stable/Release  Unable to find expected entry 'non-free/binary-amd64/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch linux.dropbox.com/ubuntu/dists/nadia/main/binary-amd64/Packages  404  Not Found [IP: 199.47.217.170 80]

W: Failed to fetch linux.dropbox.com/ubuntu/dists/nadia/main/binary-i386/Packages  404  Not Found [IP: 199.47.217.170 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.

The same errors also appear in the Update Manager.

share|improve this question
    
I tried: sudo rm -fv /var/lib/apt/lists/* && sudo apt-get update with no luck. Same error. – kelorek Dec 10 '12 at 5:33

In some cases if you switch to 'Server for United Stages' solves your problem. Because, the selected server if not synced with the mains would result in 404s.

share|improve this answer

I haven't verified this article, but check it out and see if modifying the /etc/apt/sources.list will fix your problem.

share|improve this answer

What you should do is edit your /etc/apt/sources.list file to make it look like this: (you can edit with gedit as superuser, or vim using sudo or however you like it the most)

deb http://packages.linuxmint.com/ nadia main upstream import
deb http://archive.ubuntu.com/ubuntu/ quantal main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ quantal-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ quantal-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ quantal partner
deb http://packages.medibuntu.org/ quantal free non-free

#deb http://archive.getdeb.net/ubuntu quantal-getdeb apps
#deb http://archive.getdeb.net/ubuntu quantal-getdeb games

then make an update

sudo apt-get update

and the upgrade

sudo apt-get upgrade

You shouldn't see that error anymore...

share|improve this answer
    
I still get a couple of 404 errors and trying to connect with packages.medibuntu.org will take an eternity. – Suzana_K Aug 28 '14 at 14:09

I am currently running Linux Mint 17 (64-bit) and I have had the same problem with this and earlier versions of Ubuntu and Linux Mint (32-bit and 64-bit). What usually works for me is to delete all the files in the /var/lib/apt/lists directory and to delete the /var/lib/apt/lists/partial directory by issuing the following commands:

cd /var/lib/apt/lists/

sudo rm *

sudo rm -r *

sudo apt-get update && sudo apt-get upgrade

Usually, this takes care of the 404 errors, but now and then, I have to dig a bit deeper to ferret out the problem. I hope this helps.

share|improve this answer

This is the solution that worked for me: updating the lists to use old-releases.ubuntu.com

sudo sed -i -e 's/archive.ubuntu.com\|security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list
sudo sed -i -e 's/archive.ubuntu.com\|security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list.d/official-package-repositories.list
sudo sed -i -e 's/archive.ubuntu.com\|security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list.d/official-source-repositories.list
share|improve this answer
up vote 0 down vote accepted

I cross-posted this issue to the Linux Mint forums here.

The nice folks over there were able to help me with most of the issue.

The sources.list* files were auto-configured improperly. The problem is there is no Debian nadia repository as viewed here:

http://download.virtualbox.org/virtualbox/debian/dists/

Open a “Terminal” and edit the /etc/apt/sources.list like this; using nano as an example but feel free to use any text editor you like:

sudo nano /etc/apt/sources.list

Then replace that line, deb http://download.virtualbox.org/virtualbox/debian nadia contrib with this one in sources list:

deb http://download.virtualbox.org/virtualbox/debian quantal contrib

Save the file and then run this update command:

sudo apt-get update

Followed by this upgrade command:

sudo apt-get upgrade
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .