Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Yesterday, I had an issue with my laptop: it didn't boot any longer. On startup, grub was started, but not with the normal menu, but just with a command line.

When I tried to enter commands (which weren't echoed), it gave me the error mentionned in the title.

I then booted the PC with a resue USB stick tried to re-install grub, but that didn't help either.

I give the solution in an answer below, but would like to know what was the real reason...

share|improve this question

1 Answer 1

The problem was that there were — among others — two files in my /boot/grub/: stage2 and stage2.old. The latter hat a file date of January 2012, while the former has been changed in the last days. I replaced stage2 with stage2.old and it worked again.

Nevertheless, I would like to know if anybody else had this issue as well and maybe knows where this file change came from...

share|improve this answer
    
I am also having the same problem, but the solution you posted is not working in my case. –  ps06756 Sep 30 at 9:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.