Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a homegroup here I need to be on to allow access to the network to my E: drive to DLNA devices and other computers. But the Users directory does not need to be shared at all. One would think that you don't need to be on a homegroup to share E:, but with some Samsung devices this apparently is important.

Nonetheless I cannot stop the Users folder from sharing on boot (after boot, I can always unshare it until the next boot-up). I have read about and tried the following:

  • unchecking "Share this folder" from Advanced Sharing
  • removing Everyone from the Security tab for the folder
  • unchecking "Use Share Wizard (recommended)" from Folder Options

The only option that works is leaving the homegroup. However, this is not the desired solution.

When I boot up, Users is shared and my own Library folder is the only file open under Computer Management->Share Folders->Open Files. I mean this "Library folder": C:\Users\RobertoTomás\AppData\Roaming\Microsoft\Windows\Libraries My own user account is the one that has it open.

The security permissions there list HomeUsers and WMPNetworkSvc which I can't get rid of from there without them coming back again on reboot. I'm really not sure where to go from here.

I need to: 1. continue using the Homegroup so the DLNA devices can access my shared data on E:, 2. not share Users, and 3. stop my Libraries folder being shared/open on the network.

How can I do this?

share|improve this question

closed as off-topic by mdpc, Kevin Panko, Mokubai Apr 23 at 19:38

  • This question does not appear to be about computer software or computer hardware within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

    
crazy there's still no answer. windows 10 is coming out soon! –  roberto tomás Feb 1 at 16:10
1  
I'm voting to close this question as off-topic because the asker no longer has this problem and therefore cannot check if an answer is correct. –  Kevin Panko Apr 23 at 14:25

2 Answers 2

I know this answer is 3 years after the question was asked.

  1. File/Folder > Properties > Sharing
  2. Share > Remove Homegroup from users
  3. Advanced Sharing > Uncheck Share this File/Folder
share|improve this answer
    
ooh remove homegroup sounds maybe right — I honestly dont have this problem any more and will flag the question, but thank you :) –  roberto tomás Apr 20 at 21:11

Firstly, to say that I have got Homegroups working as designed, but they are 'flaky'.

Secondly, I do wonder if this problem is due to homegroup at all. If I were you, I would go to:
Control Panel\Network and Internet\HomeGroup and see what sharing you can control from there.

Thirdly, are you able to 'Take Ownership' of the offending folders, then set the restrictive permissions you want?

Tip: To get a handle on Homegroups have at least 3 machines. I always seem to see different things on different machines, and this gives clues as to what's wrong (and what's working).

share|improve this answer
    
@robertotomás Sorry, I misunderstood the question. –  Guy Thomas Dec 13 '12 at 8:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.