Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am new to mac and OSX, and I installed MacPorts, and a few minutes later I realized that I confused it for another program that I intended to install. Now I have no idea how to uninstall it. I have seen this guide but I don't have a Applications folder. I have looked in Libraries and others, but didn't find the installation folder. At last I ran the command du -h | grep '[Mm]ac[Pp]ort' and got the following output:

268K    ./Library/Developer/Shared/Documentation/DocSets/
316K    ./Library/Developer/Shared/Documentation/DocSets/

Could it be that the installation didn't even finish? I remember having a shinny "V" and the word "Successful" when the installation ended.

I am running Mac OS X Version 10.7.5


I just checked that all the directories in that guide don't exists, but still I can run the program. This is my console:

$ port -v 
MacPorts 2.1.2
Entering interactive mode... ("help" for help, "quit" to quit)
[Users/username] > quit
share|improve this question
Do you want to uninstall the whole of MacPorts or a program installed via MacPorts (In which case: see… ) – Hennes Dec 11 '12 at 5:25
I what to uninstall the whole MapPorts program. I haven't used it really so no dependencies should exists (unless at installation it added some defaults) – Kahil Dec 11 '12 at 5:59
up vote 5 down vote accepted

You have the correct guide:

The key command to run on that page:

% sudo rm -rf \
/opt/local \
/Applications/DarwinPorts \
/Applications/MacPorts \
/Library/LaunchDaemons/org.macports.* \
/Library/Receipts/DarwinPorts*.pkg \
/Library/Receipts/MacPorts*.pkg \
/Library/StartupItems/DarwinPortsStartup \
/Library/Tcl/darwinports1.0 \
/Library/Tcl/macports1.0 \

If /Applications/MacPorts doesn't exist (don't forget the leading slash; highly unlikely you don't have /Applications at all), and the other directories in that that sudo command line are gone, especially /opt/local, it's uninstalled.

share|improve this answer
Please read my edit. – Kahil Dec 17 '12 at 13:40
@Martin: type which port -- where is it picking up the port binary from? On my system, it's in /opt/local/bin, which shouldn't exist if you've run the command above. – ckhan Dec 17 '12 at 18:45
You are right, That fixed it. I probably missed the first.... :) – Kahil Dec 17 '12 at 18:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.