Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to get an iPad to list Exchange room resources in its calendar.

I have set up an account for the iPad to connect to exchange with it's own mailbox. This account has full access to the room resources (this was mainly for my ease of testing).

As these are resources rather than mailboxes, I cannot simply add the additional accounts as exchange accounts.

I have tried sharing the calendars as .ics but cannot do this as it would appear a user can only do this to their own account.

I have tried using OWA but as this is an iPad, it can only do it in the stripped down version and hence I cannot add extra calendars.

Is there any way to achieve what I am after that I'm overlooking?

share|improve this question
add comment

3 Answers 3

It looks like you'd want to create an account with delegate access to the room mailbox, then add that account.

share|improve this answer
    
If you have delegate access to the calendar, does that mean that the room calendar items display in your calendar? –  Miles Hayler Dec 17 '12 at 8:51
    
Yes. –  bb010g Dec 17 '12 at 13:48
    
Being the delegate still requires opening the other calendar. Per the link you posted: link –  Miles Hayler Dec 17 '12 at 14:52
    
Is it not able to be enabled on the iPad? –  bb010g Dec 18 '12 at 4:21
    
I cannot add the calendar, regardless of whether the account is a delegate or not. –  Miles Hayler Dec 18 '12 at 10:33
add comment
up vote 1 down vote accepted

Solved.

The vast majority of this is PowerShell script. (Start > Powershell Modules)

First of all you need to set up the web proxy: (to be honest, I skipped this bit as the iPad in question will never leave the building and an external URL isn't required)

To check settings:

Get-ExchangeServer |fl

To set setting:

Set-ExchangeServer -Identity "MAIL01" -InternetWebProxy "<Webproxy URL>"

Next, the virtual calendar directory needs to be set to shared:

To check settings:

get-owavirtualdirectory |fl

To set setting:

Set-OwaVirtualDirectory -Identity "CAS01" -ExternalUrl "<URL for the CAS01>" -CalendarPublishingEnabled $true

Next, in the Exchange Management Console, go into Organisation Configuration > Mailbox and create a new policy. Set the domain to Anonymous (this is the bit that threw me as I assumed using the * wildcard for domain would do what I was after but no!) and the sharing settings to Calendar sharing with free/busy information and whatever level of access you want to give people.

Despite setting the policy, it didn't seem to work, I had to run the following command:

Set-MailboxCalendarFolder -Identity <mailbox alias>:\Calendar -detaillevel fulldetails -publishenabled $true -reseturl

At this point you can see the mailbox's url (both as an html to view and an ics to subscribe to) by running:

get-mailboxcalendarfolder -Identity <mailbox alias>:\calendar

At this point, I believe it's sorted. As an added extra though I figured out how to send an email from the calendar account. First log into OWA as you would normally (note, your account needs to have a level of control of the room account. I had mine set to full control and send as), then change the url to https://<OWA url>/owa/<full email address of room>/#

Apologies for any lack of detail or terminology. Hope it all makes sense.

share|improve this answer
add comment

Check out CalendarONE

It enables you to add all your shared Exchange calendars to the native iOS calendar.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.