Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently bought a Seagate Expansion 3TB (STBV3000300) external hard drive and tried running it on my computer with Windows 7 installed on it. It is not being detected by the computer. I tried reconnecting it to the different usb ports in the same computer but still no success. I tried using Disk Management Utility of Windows, the Hardware and Device Troubleshooter, but nothing seems to work.

In order to ensure that there is no fault with the motherboard or any of the usb ports, I used another Seagate Hard Drive in the same usb port and it worked fine. Then I installed Linux Ubuntu 12.04 on the same computer and the same 3TB works fine in Ubuntu.

For more details of the steps I tried refer here : http://forums.seagate.com/t5/FreeAgent-Products/Seagate-Expansion-3TB-STBV3000300-Driver-not-detected-in-Windows/td-p/183410

PS : I know there was an already existing thread at Windows 7 not detecting external hard drive but Ubuntu is detecting. Why? but I don't think that is the same issue as mine (hence I don't think this is a duplicate)

share|improve this question
    
Same question arises here what do you see when you use sudo fdisk -l? –  avirk Dec 11 '12 at 15:02
    
I am not sure how am I supposed to run |sudo fdisk -l| (in Windows) since that is where the drive is not detected. It's detected perfectly fine in Ubuntu. –  Saurabh Dec 12 '12 at 20:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.