Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have this weird problem with a Windows Vista desktop PC. It uses a wired USB keyboard and mouse and they both worked perfectly for several years. Then all of a sudden one day the keyboard and the mouse stopped responding after I started the computer. The day before I did a complete shutdown of the computer by clicking on the shutdown option from the start menu. So had not done anything inappropriate. I did a normal shutdown like I always do.

The computer starts normally, passes the BIOS POST, with no remark about the keyboard not being recognized or anything like that. Then I get to the Windows welcome screen. I try to type in my password to log in and nothing happens. I try to move around the mouse but the cursor just stays centered at the screen and does not move.

The only working solution for this so far has been to unplug both the keyboard and the mouse and then plug them back in and then all of a sudden they both work again.

This problem also occurs if I put the computer to sleep or the hibernation mode, and then wake it up. On wake up everything works again, all components initialized again, I get the signal and picture on the monitor and everything, except for the keyboard and the mouse. I unplug the mouse alone and plug it back in, I go to the Device Manager and I see that both the keyboard and the mouse are recognized by Windows. Yet they are not responding when I try to use them. How come?

I even tried to swap the connections, so that the USB port that the keyboard was connected to gets the port that the mouse was connected to and vice verse. So that Windows would register these two devices again, now on different ports. Windows shows the usual message that devices were found and it searches for drivers, founds the drivers and the devices are ready for use. But this did not solve the problem.

So in short:

  1. OS is Windows Vista (Home Basic)
  2. Keyboard and mouse are USB
  3. Keyboard and mouse are wired
  4. No mentions of keyboard or mouse not working during BIOS POST
  5. Both have working drivers in Windows
  6. Both are recognized in Windows
  7. Neither of them are responding or giving any output
  8. Swapping ports doesn't solve anything

I have a feeling this could be somehow related to Windows Update, but I'm not sure how. There was this occasion once when Windows Update tried to push out a graphics driver for Nvidia Geforce 8500 GT that is about one year older than the current version on the system. That alone makes you wonder how stupid isn't the Windows Update system? This install of course failed over and over and over again. Until I changed the preference to not install updates automatically, and I hid this moron of an update in the list of available updates.

Before I trash this Windows install and install Windows all over again, do you guys have any ides on how to solve this? If I have to dig into the registry I would be glad to, because I don't care if I brake it, I'm tired of it anyway. And besides, I know how to reinstall Windows, it's just that it's a pain in the butt to have to reinstall every application just because of this stupid problem.

share|improve this question
1  
(Please ignore this comment if you have only two USB ports.) Can you try a different USB port and/or a different USB device to connect to the same port and try the process of using the USB device >> putting the computer to sleep >> waking it up >> trying to use the USB device again? What I am trying to say is it might be a hardware problem and it would be nice to be able to rule that out. –  kush Dec 11 '12 at 15:20
    
I accept this as the solution to the problem. It only took some more time and little more fiddling with USB ports and devices and plugging and unplugging connectors back and forth to solve this. –  sammyg Dec 11 '12 at 18:22
    
Please write your update as an answer and mark the question as solved? If you need encouragement, I can guarantee you one upvote for your trouble. :) –  kush Dec 11 '12 at 18:54
    
Good idea! The update is now cut from the answer and pasted as a solution to the problem. Thanks for the help! –  sammyg Dec 11 '12 at 20:07
1  
Thanks! I will only be able to accept my own answer in 2 days. –  sammyg Dec 11 '12 at 20:44
show 3 more comments

1 Answer 1

There are 4 USB ports. From the convenience I will call them A, B, C, and D, starting from top left one. A was mouse, B was keyboard and D was a USB hub. I tried flipping A and B and keyboard worked upon startup (from complete power down) but the mouse didn't. I moved the mouse to C and still the same situation, keyboard worked but mouse didn't unless I unplug and plug back in.

I moved the mouse back to port A and unplugged the USB hub from D port. I powered down once again, and did a started up the computer. This time both the mouse and the keyboard worked. For the last time I flipped the mouse from A to B and the keyboard from B to A, shut down, started up, and everything worked.

Then I plugged in the USB hub to D once again, shut down, started up again, and both the mouse and keyboard worked this time. I repeated this three times, with complete shutdown and startup. It worked every time. So I assume it will work now, at least for a while. It might be just enough to give me time to prepare for a complete reinstall of Windows. But for the time being it seems to work now.

It's a weird problem though... I have never had this issue with Vista before, and not with XP either. This computer however came with OEM Windows Vista Home Basic from the manufacturer. But I prefer retail versions of Windows on all my computers. This one also came with the regular non-custom version of Windows Vista media and I will try to install that one next time I do the reinstall process.

Short version for future visitors:

Try the following...

  1. Unplug all the USB devices.
  2. Plug in the devices one by one, starting with the keyboard.
  3. Wait for Windows to configure the device, and now plug in the mouse.
  4. Now shut down the computer, and start it up again.
  5. If both mouse and keyboard work now, then plug in the remaining USB devices one by one.
  6. Now shut down the computer once more and start it up again and see if everything works.

In general you have to experiment a little with different ports.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.