Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

While my motherboard is half a year old now (ASUS M5A99X EVO), I only recently made use of the USB3 boards (after purchase of USB3 external harddrive). However, I am encountering issues. I am running linux 3.6.7-4.fc16.x86_64.

Initially, the harddrive worked fine with USB3 (amazing ≈160MB/s), but I had some problems after putting the harddrive to sleep manually after use (backup) with hdparm -Y. After some time, the device disappears from lsusb and i see the following in dmesg:

[ 1924.091107] xhci_hcd 0000:05:00.0: xHCI host not responding to stop endpoint command.
[ 1924.091114] xhci_hcd 0000:05:00.0: Assuming host is dying, halting host.
[ 1924.091147] xhci_hcd 0000:05:00.0: HC died; cleaning up
[ 1924.091233] usb 11-1: USB disconnect, device number 2
[ 1924.091272] sd 6:0:0:0: Device offlined - not ready after error recovery

Testing with my (USB3 capable) notebook, I could not immediately reproduce the behaivour. I put the drive to sleep with hdparm -Y and waited for like an hour, but it was still listed in lsusb and responded after a few seconds delay when I tried after the hour of waiting. After an hour, on the desktop, the device would've usually vanished.

Googling for this issue, I came across hints that playing around with IOMMU settings and upgrading the BIOS might help. I upgraded the BIOS and tried both with and without IOMMU enabled, got similar results.

Most disturbing is, that one of the two USB 3.0 hubs sometimes also disappears from lsusb (or does not show up after boot at all). I've also heard that there are some hardware issues with ASUS USB3 ports. Applying mechanic force to the capble doesn't push the issue to one side or the other. Also, udev seems to reenumerate all devices if I plug the HDD into the USB 3.0 port without success (I can notice from my keyboard layout being changed to the default, which I do not use normally).

The drive is externally powered and the external power supply is plugged in (it also stays powered when unplugging from USB, although it will spin down then).

So before I try to return the board, I wanted to find out whether this can be anything else than a failure on the motherboard?

share|improve this question
I'd say it's pretty unlikely that it's anything else at this point, but a weird corner-case driver or even BIOS problem could maybe do something like this. Personally I'd go ahead and replace the board (but as a professional system builder the effort doesn't bother me, so YMMV) – Shinrai Dec 11 '12 at 16:44
@Shinrai Thank you for your comment. The last five or four BIOS updates (forgot to mention, its UEFI) were related to USB issues, I already installed the latest version. Could still be possible of course that this problem is still not fixed if it's in BIOS, but to be honest, I doubt it. USB2 devices are also bitchy on those ports. – Jonas Wielicki Dec 11 '12 at 18:31

You must log in to answer this question.

Browse other questions tagged .