Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install Oracle’s VirtualBox.

I used sudo dpkg -i virtualbox-4.2_4.2.4-81684\~Ubuntu\~quantal_i386.deb

Getting following errors

 (Reading database ... 226237 files and directories currently installed.)
Preparing to replace virtualbox-4.2 4.2.4-81684~Ubuntu~quantal (using virtualbox-4.2_4.2.4-81684~Ubuntu~quantal_i386.deb) ...
Unpacking replacement virtualbox-4.2 ...
dpkg: dependency problems prevent configuration of virtualbox-4.2:
 virtualbox-4.2 depends on libc6 (>= 2.15); however:
  Version of libc6 on system is 2.13-20ubuntu5.
 virtualbox-4.2 depends on libqtcore4 (>= 4:4.8.0); however:
  Version of libqtcore4 on system is 4:4.7.4-0ubuntu8.1.
 virtualbox-4.2 depends on libqtgui4 (>= 4:4.8.0); however:
  Version of libqtgui4 on system is 4:4.7.4-0ubuntu8.1.
dpkg: error processing virtualbox-4.2 (--install):
 dependency problems - leaving unconfigured
Processing triggers for ureadahead ...
Processing triggers for shared-mime-info ...

How to solve it?

share|improve this question
add comment

migrated from stackoverflow.com Dec 11 '12 at 17:01

This question came from our site for professional and enthusiast programmers.

1 Answer

libc6, libqtcore4, libqtgui4 these three packages have lower version than the required version. Use synaptic package manager to locate these packages latest version and install it, or you can alternatively use "sudo apt-get install package_name"

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.